Endless blackscreen before install screen

Hi everyone,
I’ve been trying to install Qubes 4.0.4 on my old HP Pavillion 14-bk0xx Laptop (Specs: i3-7100U, 8GB, 128GB SSD). I am booting from a a 64gb USB 3.0 flash drive and have turned off secure boot and enabled legacy boot and virtualisation.

What happens is I choose boot from usb and it boots from the usb, then it goes to a screen that contains XEN: console text and then continues on to a black screen, I dont get as far as any sort of install screen or menu.

I’ve tried different usbs, different qubes versions (3.2.1) and different usb ports to see if any of these could be the cause but the same result.

Any advice would be greatly appreciated.

Did you try everything listed here: Installation Troubleshooting | Qubes OS

1 Like

Yeah I’ve made my way through it and still no luck on 4.0.4.I tried another usb with 4.0.4 and it made no difference (To check if it could be something wrong with my main usb), but when I loaded the usb with 3.2.1 it let me boot and install.
So I think it might be something in 4.0.4 that is clashing with my laptop’s compability.

1 Like


Can you tell me how to boot the xen.efi instead? Maybe this will move me forward.

I am getting similar behaviour trying to install Qubes 4.0.4 on a similar type of machine. I was able to move past the black screen by using the method of DD the ISO to the USB thumbstick; after giving up on the flash media creator methods.

What is happening now for me is Xen is failing not booting to the installer.

Currently Xen gives me the following error:
error 0002
panic on cpu 0
fatal page fault
faulting linear address ffff82d0d4642b99

I have tried booth UEFI and Legacy boot modes on the machine. I have disabled protected boot.
Following the Qubes wiki as well as related post on git hub [UEFI-Only] Installer not starting, troubleshooting didn't solve the issue · Issue #3444 · QubesOS/qubes-issues · GitHub I have edited the [qubes-verbose] entries in the bootx64.cfg config file: console mode to none instead of vga, turning on/off noexitbooot, mapbs, and the efi options were applicable. No configuration change seems change the behaviour.

HP 15-ay015XX series
CPU: Intel Core i3-6100U (2.3 GHz, 3 MB cache, 2 cores) I have confirmed the CPU does support VMX and
Memory: 8GB
Secure Boot: Off
Virtualization: On
BootUSB memory: 128GB (USB 3.0)

This may be related to an issue I’m currently facing. While qubes is installed from the 4.0.4 testing iso released some months ago, after the latest update an endless blackscreen can appear right after booting. For me it works if pressing “Advanced options for Qubes (with Xen hypervisor)” in the GRUB Boot menu and selecting the “Qubes, with Xen 4.8.5-30.fc25 and Linux 5.4.98-1.fc25.qubes.x86_64” manually. Am also using an 128GB SSD laptop.

How can I get to “Advanced options for Qubes (with Xen hypervisor)” in Grub for the USB media? I never get Xen to finish booting.