EFI Troubleshooting ThinkPad T480

There is a commum bug in UEFI implementation that affects mostly lenovo system, so when i finish the qubes instalation i have to enable MAPS and NOEXITBOOT by editing /mnt/sysimage/boot/efi/EFI/qubes/xen.cfg, but when i list this directory and the file doesnt exist on qubes 4.1. it looks like moved from xen.cfg to /boot/efi/EFI/qubes/grub.cfg. what are my options to fix this issue? because when i boot my laptop after the installation it hangs on black screen and doesnt recognize qubes, the troubleshooting documentation dont have updates to fix this, so im stucked on this problem

qubes doesn’t use xen.cfg in 4.1+, so the files looks normal.
try boot into qubes os rescue, skip to shell and run this :

efibootmgr -v -c -u -L Qubes -l /EFI/qubes/grubx64.efi -d /dev/sda -p 1 "placeholder /mapbs /noexitboot"

change /dev/sda and partition number to your actual efi drive and partition.

i tried to create a xen.cfg but it didnt work too

how i see my actual efi drive and partition

if you do automatic partition, or manual then automatic create,
your efi should be 600mb, and boot is 1gb

efi partition is 1 and boot partition is 2 as default,
run lsblk then post it here if you unsure.

Ok… now i made a new installation and finished it, Im on tty2… here is the lsblk

run this efibootmgr -v -c -u -L smlt -l /EFI/qubes/grubx64.efi -d /dev/nvme0n1 -p 1 "placeholder /mapbs /noexitboot"

and you can remove qubes entry by efibootmgr -b #### -B (change # to original boot number provided by running efibootmgr -v

after reboot, select smlt in uefi entry,

This is the response


And no boot again

wait, you have 2 mistake :

  1. why you add /mnt/sysimage/boot/efi there, just run what i provide efibootmgr -v -c -u -L smlt -l /EFI/qubes/grubx64.efi -d /dev/nvme0n1 -p 1 "placeholder /mapbs /noexitboot".

  2. it’s my mistake that i didn’t tell you what the option will do. efibootmgr -b #### -B is actually delete an uefi entry, i tell you that to delete original boot number (i mean original is created by the installer which the original boot number is 0001). You should just delete the entry by run `efibootmgr -v -b 0001 -B.

just boot into qubes os rescue, press 3 to skip to shell and run this command from number 1, no need to add anything.

Ok um making a new installation…

no need, it’s just an uefi entry, it doesn’t affect anything to your data.

Ok done… try to boot now

Still not booting

I have done As you said but when List the directory the \EFI doesn’t exist, see the it in the end of the image

no no, there’s no related to that, the uefi entry is good, so adding mapbs and noexitboot on uefi entry will not resolve your problem.

what’s your storage mode in bios, ahci / ide ?
are you using external drive like nvme enclosure ?

On qubes 4.0 I only copy the .cfg on sysimage and add mapbs and Noexitboot and it works perfectly, no I don’t use external drive and it is ahci

try turning off legacy mode in your bios, if still not work, try installing qubes in legacy mode.

what i can say is, your original qubes entry is good the difference between what we add before is just adding mapbs and noexitboot.

Thank you for your help brother, but I’m going back to 4.0. No problem with 4.0 and runs perfectly!

When I entry on rescue mode it shows that directory \EFI doesn’t even exist

And boot directory don’t have the respective too