Dom0 update fails after 4.1 upgrade

After upgrading ti qubes 4.1, I have a notification to update dom0. Attempted to update via salt and via CLI, same outcome, but slightly different beahviour.
I have minimal debian-11 template as firewall, so I have already tried create a sys-update appVM based on fedora-35 regular template and specify it as update VM, same result.
When a try to update via CLI, I see a glimpse of a list os updates in the window of the updateVM, bur it disappears immediately. Then dom0 terminal says “No updates available”.
When I try via qubes update, it gives the folowing error message:

"
Updating dom0

[ERROR ] Failed to import module localemod, this is due most likely to a syntax error:
Traceback (most recent call last):
File “/usr/lib/python3.8/site-packages/salt/loader.py”, line 1685, in _load_module
mod = spec.loader.load_module()
File “”, line 522, in _check_name_wrapper
File “”, line 1027, in load_module
File “”, line 852, in load_module
File “”, line 265, in _load_module_shim
File “”, line 702, in _load
File “”, line 671, in _load_unlocked
File “”, line 848, in exec_module
File “”, line 219, in _call_with_frames_removed
File “/var/cache/salt/minion/extmods/modules/localemod.py”, line 222, in
@decorators.which(‘locale-gen’)
AttributeError: module ‘salt.utils.decorators’ has no attribute ‘which’
local:
----------
"
This happens consistently on 2 identical machines.
Can someone more knowledgeable than I suggest how to investigate further and / or help reporting to devs.

Regards

1 Like

Problem solved.
Thank you for your help.

Regards