Dom0 GUI "Start Qube on Boot" Fails | Modify Qube Settings from CLI

A long time ago in the Dom0 Qube Manager, I enabled the “Start qube automatically on boot” for my work qube by checking the box. Now, I’d like to disable that, because I don’t need work to start on boot anymore.

When I uncheck the “Start qube automatically on boot” box, and then click apply, the box re-checks itself. If I exit the Qube Manager and then re-open it, the box is still checked, and after restarting the machine, work does indeed start automatically on boot (meaning the GUI is likely not misreporting anything; rather the GUI isn’t writing the change to the checkbox). It seems I’ll need to modify the config files that the Qube Manager GUI pulls from.

Where are these config files? I’d probably be able to figure out which bit(s) to modify from here to “uncheck” the “start on boot” option, but if you happen to have an idea, I’d be open to suggestions.


It might be useful to have a section in the documentation that lists the files from which important Dom0 GUIs pull their information. For example my XFCE Panel sometimes displays two “Wifi” icons, or drops the “Whonix” icon. This isn’t a bug for the devs to spend time on over other things, but if I knew which config/error log files to look at, I could try to fix this myself.

1 Like

Edit: I was able to uncheck the box by first unchecking it and then clicking “Ok” instead of “Apply.” After clicking “Ok” and exiting the GUI, then box remained unchecked when I reopened the GUI. I did not have to ever click “Apply.”

I should mention that I tested this after switching to the i3 Window Manager. I don’t know what config files i3 would change normally, let alone on a Qubes install, but it’s possible that i3 could have changed something that allowed me to uncheck the box.

I’ll switch back to XFCE soon to see if the box goes back to being checked (or won’t uncheck after being checked) upon switching out of i3.

1 Like