Dom0 admin password reset

Hello everyone,

I’m not sure what exactly didn’t go right during the initial configuration but Qubes4.1 is not taking the password I did setup for dom0 admin.

Is there a way to reset this account password or I have to re-enstall the OS?

Thank you,

BTW Encryptuon password works fine

Hi John,
Did you actually set up a root password, or is this the user password for
logging in?
If you can log in as user then you should be able to use sudo su - to
get root, and then passwd to change the root password. But there is
really little point in having a root password in Qubes.
If you cannot log in as user (or whatever username you selected at
install) then you can recover the situation using any live iso.
Many problems that people have in Qubes are actually not Qubes specific.
This is one of those.
You can find many guides online to changing password: e.g.

The only Qubes specific part is that you will have to decrypt the
encrypted partition before chrooting in to it.

I dont know if you can use the install disk in recovery mode to just
change the password. It’s worth checking that as an easy option.

If you find this somewhat daunting, dont worry. Just summarise exactly
what you have tried and someone here will help.
It is, of course, easier (if no data is at risk) to just reinstall.

I never presume to speak for the Qubes team. When I comment in the Forum or in the mailing lists I speak for myself.

Yes, I tried recovery mode from the USB install drive but couldn’t find how to reset users password even after decrypting hard drive. Considering no data at all on this new setup, I ended up simply re-installing my OS and keep playing with this nerdy OS :wink:

Thank you everyone

1 Like

Fair enough - simplest in your case.
Enjoy Qubes - if you hit any other problems, or want some advice, dont hesitate to ask.