Does Not Boot After Install (Desktop MSI Z490-A PRO i7)

Hi, I installed Qubes successfully. After clicking the restart button and unplugging the USB drive-- even with the Hard Disk as the first boot option-- the computer only boots into BIOS. What am I doing wrong? I can’t find anything in the knowledge base about this. Please help give me a clue about what’s wrong!

Hardware: MSI - Click Bios 5
Z490-A PRO (MS-7C75)

I read the Installation guide about 3 times all the way through word for word. I have done everything correctly up until this point:
" If the installation was successful, you should now see the GRUB menu during the boot process."

Again, the installation was successful but upon reboot the computer goes into BIOS. I have tried UEFI and CSM. I have not ever seen the GRUB menu and do not know how to troubleshoot. I have been Googling for hours.

Changing to CSM reveals that the boot device is not detected. Secure Boot is not enabled.

I’m willing to pay money for someone to help.

have you checked there page: (2 different link)

Try using qubes os 4.1 install in uefi mode.

1 Like

This did not work. In rescue mode it did not recognize any commands such as:

pkill -9 anaconda
anaconda --rescue

It said no Linux partitions found.

I tried locating the folder /boot/efi/EFI/qubes within the ISO and it was not there.

I tried everything in this article: "No bootable device found" After completing qubes os install - #2 by EncryptedGiraffe

I got “EFI variables are not supported on this system when I attempted the efibootmgr command.” until I switched from CSM back to UEFI. I can’t boot qubes I have tried everything.

Tried that, it didn’t work.

have you tried to redownload the iso?


Seems like no solution there, but maybe you find something helpful still…

Not redownload but to verify it.

1 Like

I got the ISO directly from the website and verified it using PGP. In the troubleshooting documentation, it is outdated and those file location paths no longer exist in version 4.0.

1 Like

Issue still unresolved. Unable to boot into grubx64.efi. It boots directly into BIOS instead. No BIOS firmware update is available because it’s OEM. Willing to pay $100 to anyone that can get this working. The $4000 computer is currently still just a brick.

How did you create your installation medium? Using Rufus or linux dd?

try reinstalling 4.1-rc4, just do automatic partition in storage menu.
reboot when installation is done.

If your system still boot into bios,
boot into qubes os rescue (boot it from your installation medium).
input 3. skip to shell, then type efibootmgr -v and show the output here (take a pict).

Already tried all of these things. It does not boot into Grubs. I need someone to actually help. I will pay anyone that actually hows how to help instead. I have tried fucking everything.

Tried flashing BIOS, OEM is impossible to flash. Tried this tool: Forum UEFI Shell Flash tool [V1.16] for MSI boards! ✔ | MSI Global English Forum - Index (didn’t work)

what happen if you try to add uefi entry,
efibootmgr -v -c -u -L "Qubes OS" -l /EFI/qubes/grubx64.efi -d (your EFI drive) -p (which partition)

-d could be /dev/sda /dev/sdb /dev/nvme0n1 /dev/nvme0n2
-p could be 1 or 2

@nyg33, please understand that this is not a customer support forum, it is community support. If someone is willing to be payed to troubleshoot that for you that’s with them, but please don’t just disregard other’s efforts, trying to help.

I can no longer get to command line, it’s just a black screen when it tries to boot off of the flash drive now.

Apparently there is no one here skilled enough to assist. Mods don’t help, just attack the person begging for help. I am offering $200 for anyone that can get this shit installed. I have worked with several people and no luck.

I seriously doubt that you attitude will help you solving you problem - in the contrary if you ask my humble opinion!

That said, as I understand this happened after initial setup. Yes? I would not even bother investing much time in troubleshooting in such a case. For what exactly? There is no use- or meaningful data you might wanna retain.

I would just reinstall the system. Probably testing it on another storage device. The install takes a couple of minutes. Even writing your posts might take you twice as long as a fresh install.

But again - work on our attitude towards other people or you will have a difficult time with community projects as Qubes. As others tried to tell you already. All the people here do this in their SPARE TIME FOR FREE! I hope you get it. Peace and good luck - I’m out.