Do not disturb mode?


On modern desktop environment, it’s possible to enable a “do not disturb” mode to disable notifications, this is particularly handy when you show something on your computer to someone.

However, I’m not sure it’s possible to achieve that on Qubes OS, right? This is embarrassing for physical privacy protection. :confused: I’m not sure how to could be implemented, except by setting the knob into running Qubes, and the one that may start after…

How about simply pause or shut down the VMs related to notifications?

Using pause should works indeed, but only if notifications come from a different qube than the current one.

Hopefully you are using the compartmentalization principle which makes Qubes OS secure, so your communications are not in the same qube as other things.

Also note that the pause functionality is somewhat experimental.

1 Like

It’s up to the user to decide the compartimentalization :wink:

But a common use case would be to have multiple tabs opened in a web browser. It’s not realistic to use a qube per tab, and not practical to close all other tabs when you just want to show your screen.

It sounds like this should be an upstream feature request for Xfce. We mostly inherit dom0’s desktop environment and such features from them.

1 Like

It is suppose to already exist using the command line: apps:xfce4-notifyd:faq [Xfce Docs] :slight_smile:

But I can’t get it to work :confused:

$ xfconf-query -c xfce4-notifyd -p /do-not-disturb -T
Property "/do-not-disturb" does not exist on channel "xfce4-notifyd".

It seems the xfce-notifyd isn’t recent enough in dom0 xfce4-notifyd's Do Not Disturb from command line? / General discussion / Xfce Forums , there is a good chance it’s fixed in R4.2 with a more recent fedora :slight_smile:

Solved by Disable notification per XFCE Qubes