Debian 11 minimal cant access repo

I am not able to install in standalone vm created using debian-11-minimal. Any idea how to fix this?

Edit: I am using Qubes OS 4.1.2-rc1

Below are the steps

  1. Created a standalone vm using debian-11-minimal


  1. Opened xterm with root access using command qvm-run -u root deb-11-standalone xterm

  2. Run the command sudo apt update and I see below error. Not just the update command, I tried to install qubes-core-agent-passwordless-root and got same result.

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

Err:1 bullseye InRelease
  Temporary failure resolving ''
Err:2 bullseye-security InRelease
  Temporary failure resolving ''
Err:3 bullseye InRelease
  Temporary failure resolving ''
Reading package lists...
E: Failed to fetch  Temporary failure resolving ''
E: Failed to fetch  Temporary failure resolving ''
E: Failed to fetch  Temporary failure resolving ''
E: Some index files failed to download. They have been ignored, or old ones used instead.

debian-11-minimal template does not have qubes-core-agent-networking installed.

This ought work for you …

  1. Clone debian-11-minimal to debian-11-minimal-networking
  2. Start debian-11-minimal-networking
  3. From Qubes Manager, highlight debian-11-minimal-networking & click “Open console in qube” button
  4. Login via console and enter:
apt install -y qubes-core-agent-networking && poweroff
  1. Use your fresh debian-11-minimal-networking as you tried to do with debian-11-minimal


Depending upon your use case, you may wish to install qubes-core-agent-passwordless-root directly into the debian-11-minimal-networking OR manually install into your new debian-11-standalone AppVM via console just as you did for debian-11-minimal-networking.