Dark mode in Fedora-33-minimal VM


How can i make my minimal fedora-33 to be dark? I’ve tried what i did in debian-10-minimal:

  1. Started a xterm as root
  2. Installed gnome-themes-extra
    dnf install gnome-themes-extra

In the debian minimal there was a .config folder under /home/user, but there is none in fedora-minimal. I’ve tried to create it and the 2 folder inside it (gtk-3.0 & gtk-4.0) and the settings.ini files with the correct content from the documentation. Unfortunately it didn’t work.

Can someone help me out how to make the fedora minimal VM dark?

Thanks any help!

You are trying to specify gnome-terminal configuration; the minimal templates do not have gnome-terminal installed by default.

Either install gnome-terminal, or look into specifying xterm resource configuration in ~/.Xdefaults.

Quick ways without modifying config: xterm -fg gray -bg black or ctrl+middleclick: enable reverse video

Regarding to the documentation i thought if i download adawaita-dark theme with the gnome-themes-extra package i will be able to configure the whole system to force the dark mode. At least it’s worked in debian-minimal. Aren’t they the same in specifics (minimal fedora & minimal debian) and somehow in settings? I know they are using different package managers and fedora has more up to date packages, but other then these whats are the differents?

I just dig the internet as i could, and the only thing i’ve found is the xsettings daemon, but i couldn’t find any xsettings related package in the fedora repository. Does anyone know how to force the entire fedora minimal VM to be dark?