CPU stuck on installation - ThinkPad X1 Titanium

Hello everyone,
I tried to install Qubes 4.1 on Lenovo Thinkpad X1 Titanium:

  • cpu: i5-1140G7,
  • gpu: Intel Iris Xe,
  • bios: 1.19 N2MET54W.

My BIOS settings:
Hyper-Threading: Disabled
Inter Virtualization Technology: Enabled
Intel VT-d Feature: Enabled

I am using the installer on a USB via thunderbolt adapter.
After selecting “Troubleshooting - verbose boot and Install Qubes” i get the message (XEN) Xen is relinquishing VGA console.

After I edited the grub:

..xen.gz console=vga vga=current,keep guest_loglvl=all
..X86_64 console=hvc0 acpi=off

i get the message
watchdog: BUG: soft lockup - CPU#2 stuck for 24s! [swapper/0:1]

Searching for a solution to the problem, I found many topics related to CPU soft lockup on 11th gen processors.
I tried to edit grub by adding:

..xen.gz console=vga dom0_max_vcpus=1 dom0_vcpus_pin vga=current,keep guest_loglvl=all
..X86_64 nouveau.modeset=0 i915.force_probe=*

but it didn’t help.

What could be causing the problem? Xen version?
What can I do?