Corrupted TemplateVM

Hi Guys,

I’m having problem with my personal templateVM. I can’t open any apps on my templateVM (terminal, browser, file browser, etc.), However, I can access it thru xl console, but the problem is it doesn’t have any internet connection. I already try to change the connection to sys-net, and VPN but still doesn’t work. I also try to change the config in /etc/qubes-rpc/policy/qubes.Updateproxy and still didn’t work. I checked the netstat -nlptu from my template and it looks like it doesn’t have the 8082 proxy something.

I also tried update with http_proxy= https_proxy= sudo apt-get update and still did not work.

Can someone help me out with my problem?

Maybe you can just create a new personal templateVM from a default Qubes OS template and delete this faulty one?
You can try to recover your personal templateVM as well, but you’ll need to check its log (for example using sudo journalctl in its terminal) for errors and then try to fix them.

already did that, I guess it breaks when the update didn’t finished, that’s why I’m trying to update it. but there are no internet connection when I’m accessing it from xl console.

Could it be out of free space?

nope, there’s still a lot of space.

Are you aware that you’re not supposed to either run apps or connect your templateVMs to the internet?

If I’m understanding correctly and you intended to use applications in the template, I recommend you to read through the basics of the Qubes OS templating system:

The gist is:

  • install software in the TemplateVM (no need to connect it to the internet for that, you’ll still be able to sudo apt install ... or sudo dnf install ...)
  • do not run the software in the TemplateVM
  • shutdown the TemplateVM
  • start an AppVM based on that template
  • run the software in that AppVM

If this is obvious to you, I misunderstood what you said and I’m sorry. If any of this doesn’t quite make sense, please don’t hesitate to ask, those are really the fundamentas and it matters to understand them right. :slightly_smiling_face:

1 Like

Yes, I’m aware of that and the reason why I connect it to my VPN and sys-net is because the proxy is not working. I know all of that, I already read it.

I’m trying to update it but the proxy is not working, I’m working on alternatives but I’m out of options.

Is downloading a fresh template and using that an option? The Updates Proxy usually just works out of the box with no tinkering required. It sounds like you might have inadvertently broken the Updates Proxy while tinkering with this template.

actually, the templateVM’s OS kernel has a problem and its already addressed with the respective team. What I did is I update it and it automatically shutdown for no reason, when I restart it, I can’t open any apps.

Whenever I tweak something, I revert it back from its original state like nothing happened.