Clock is not correct

It is off the correct time.
How do I set the correct time?
I tried running this command on dom0, but it is way off by about a minute.
sudo qvm-sync-clock

What is your Clock qube in Qubes Global Settings?

It’s sys-net.

Check the output of this command in sys-net:
sudo systemctl status systemd-timesyncd
Maybe you have this issue:

output is this.

Unit systemd-timesyncd.service could not be found.

I corrected the time manually. It is very annoying to do this every time.

Install the systemd-timesyncd package in sys-net TemplateVM (debian-11?):
sudo apt install systemd-timesyncd

I did now. Thank you!

Late to the party, but I have a similar issue in VMs which are based on a kicksecure template.

systemd-timesyncd in sys-net is up and running. When QubesOS is coming back from sleep, debian based VMs sync their clock correctly, kicksecure based VMs don’t sync their clock. Manually doing a sudo qvm-sync-clock works in both type of AppVMs.

In debian-11 VMs qubes-sync-time.service is triggered by the according timer but in kicksecure VMs it won’t as it has a condition failed.

This might be solved by manually doing a

sudo rm /etc/sdwdate.d/qubes-sync-time-disabled-by-sdwdate.marker

in the kicksecure template.

This file might be part of kicksecure’s hardening efforts, so (as always) use at your own risk.