Can't start vm after update: Failed to connect to qmemman

I was upgrading to 4.1 but didnt get that far. After just updating dom0 and re-signing /boot, things worked but couple of days later suddenly no vm can start:

Domain sys-net has failed to start: Failed to connect to qmemman: [Error 2] No such file or directory

Any advice on how to figure out what’s the problem? Dom0 terminal runs fine.

Thank you.

I also deleted /var/log/* (trying to free up some space for the upgrade) – I wonder if thats how I screwed this up?

Yes, it was.

You need at least:

mkdir -p /var/log/qubes 2>/dev/null
mkdir -p /var/log/salt 2>/dev/null
mkdir -p /var/log/xen/console 2>/dev/null
mkdir -p /var/log/libvirt/libxlk 2>/dev/null
chgrp qubes /var/log/qubes
chgrp qubes /var/log/xen
chmod 2770 /var/log/qubes
chmod 2750 /var/log/xeb/console
touch /var/log/qubes/qmemman.log

followed by a reboot.

Other directories - journal, lightdm,usbguard

1 Like

This worked. You saved my life:-) Thank you so much.

Just for anyone copy-pasting the code: you need sudo and the 8th line has a typo xebxen

Can you setup a Bitcoin/Lightning address? I would love to send you at least a small tip. The easiest way is to download Wallet of Satoshi app, it will generate email-like address for you and anyone can send you sats (Bitcoin).