Can't make QWT work

Hi, I’m new in Qubes. Firstly I was really impressed by how everything looks so simple, and ready to use. But for last few days I’m trying to force QWT to work. I read the guide many times, and now I think I followed every point that is there. One thing that I see is that on Windows Xen PV Bus driver is always marked as not working.

Then when I install QWT and add
qvm-features <VMname> gui 1
qvm-prefs <VMname> qrexec_timeout 300

GUI not starting. I also tried adding

qvm-features <VMname> gui-emulated 1
qvm-features <VMname> qrexec 1

and in that case I have GUI like before any of that change, but still not have qubes integration, and VM is killed when timeout occurs.

My qubes version:

xen_version            : 4.14.3
Linux 5.10.90-1.fc32.qubes.x86_64
Installed Packages:  
grub2-qubes-theme.x86_64                          	5.14.4-2.fc32 
kernel-qubes-vm.x86_64                            	1000:5.10.90-1.fc32.qubes 
python3-qubesadmin.noarch                         	4.1.20-1.fc32 
python3-qubesdb.x86_64                            	4.1.12-1.fc32 
python3-qubesimgconverter.x86_64                  	4.1.16-1.fc32 
qubes-anaconda-addon.noarch                       	4.1.8-1.fc32 
qubes-artwork.noarch                              	4.1.12-1.fc32 
qubes-artwork-anaconda.noarch                     	4.1.12-1.fc32 
qubes-artwork-plymouth.noarch                     	4.1.12-1.fc32 
qubes-audio-daemon.x86_64                         	4.1.19-1.fc32 
qubes-audio-dom0.x86_64                           	4.1.19-1.fc32 
qubes-core-admin-addon-whonix.noarch              	4.0.2-1.fc32 
qubes-core-admin-client.noarch                    	4.1.20-1.fc32 
qubes-core-dom0.noarch                            	4.1.24-1.fc32 
qubes-core-dom0-linux.x86_64                      	4.1.17-1.fc32 
qubes-core-dom0-linux-kernel-install.x86_64       	4.1.17-1.fc32 
qubes-core-qrexec.x86_64                          	4.1.16-1.fc32 
qubes-core-qrexec-dom0.x86_64                     	4.1.16-1.fc32 
qubes-core-qrexec-libs.x86_64                     	4.1.16-1.fc32 
qubes-db.x86_64                                   	4.1.12-1.fc32 
qubes-db-dom0.x86_64                              	4.1.12-1.fc32 
qubes-db-libs.x86_64                              	4.1.12-1.fc32 
qubes-desktop-linux-common.noarch                 	4.1.11-1.fc32 
qubes-desktop-linux-manager.noarch                	4.1.11-1.fc32 
qubes-dom0-meta-packages.noarch                   	4.1.20-1.fc32 
qubes-gpg-split-dom0.x86_64                       	2.0.55-1.fc32 
qubes-gui-daemon.x86_64                           	4.1.19-1.fc32 
qubes-gui-dom0.x86_64                             	4.1.19-1.fc32 
qubes-img-converter-dom0.x86_64                   	1.2.11-1.fc32 
qubes-input-proxy.x86_64                          	1.0.26-1.fc32 
qubes-input-proxy-receiver.x86_64                 	1.0.26-1.fc32 
qubes-input-proxy-sender.x86_64                   	1.0.26-1.fc32 
qubes-libvchan-xen.x86_64                         	4.1.7-1.fc32 
qubes-manager.noarch                              	4.1.22-1.fc32 
qubes-menus.noarch                                	4.1.11-1.fc32 
qubes-mgmt-salt.noarch                            	4.1.13-1.fc32 
qubes-mgmt-salt-admin-tools.noarch                	4.1.13-1.fc32 
qubes-mgmt-salt-base.noarch                       	4.1.4-1.fc32 
qubes-mgmt-salt-base-config.noarch                	4.1.1-1.fc32 
qubes-mgmt-salt-base-topd.noarch                  	4.1.3-1.fc32 
qubes-mgmt-salt-config.noarch                     	4.1.13-1.fc32 
qubes-mgmt-salt-dom0.noarch                       	4.1.13-1.fc32 
qubes-mgmt-salt-dom0-qvm.noarch                   	4.1.4-1.fc32 
qubes-mgmt-salt-dom0-update.noarch                	4.1.8-1.fc32 
qubes-mgmt-salt-dom0-virtual-machines.noarch      	4.1.16-1.fc32 
qubes-pdf-converter-dom0.x86_64                   	2.1.12-1.fc32 
qubes-release.noarch                              	4.1-0.27 
qubes-release-notes.noarch                        	4.1-0.27 
qubes-repo-templates.noarch                       	4.1.2-1.fc32 
qubes-rpm-oxide.x86_64                            	0.2.3-1.fc32 
qubes-usb-proxy-dom0.noarch                       	1.1.1-1.fc32 
qubes-utils.x86_64                                	4.1.16-1.fc32 
qubes-utils-libs.x86_64                           	4.1.16-1.fc32 
xfce4-settings-qubes.x86_64                       	4.0.5-2.fc32 

Windows VM is running Windows 10 Home 21H2 build 19044.1566 - freshly downloaded ISO (Polish 64-bit) from MS and all updates after install.

Ok, according to MS forum this driver issue is probably caused by insuficient power settings. So i think it can be caused by manually performed powercfg -H off that was addvised in installation guide.

It was dead end. Still can’t make QWT work.

What guide do you mean?

and follow first:

and then:

I freshly installed Win 10 more then 10 times up to now. It always ends the same. What I do is:
1.) Creating HVM not based on any kernel with 4096 MB RAM, 50GB system storage and 10GB privat storage space, 2 cores and memory balancing not ticked, no internet connection.
2.)Boot HVM from ISO and install Windows on 50GB Disk 0
3.)Reboot after installation connect to sys-firewall and update
4.) Install 7zip, unpack xenvbd and xenbus
5.) Install xenvbd and xenbus (no popup to reset after installing xenbus, and driver matched as not working from the beginning)
6.) Reboot
7.)Install QWT (from C:) with unticked, Xen PV disk drivers, Move user profiles and one more that was unchecked by default and as I understand it is option for Win 7.
9.) Add settings for VM in dom0

Unfortunately doc is outdated. Take a look this thread

1 Like

I’m little bit confused. Should I cross compile and install newest QWT or that from ftp also should work? If second what I’m doing wrong? In those reports there is nothing about installing additional xendrivers. So are they detracted in this solution?

Building from source is the optimal way to make it work for now.

Ok, just build it. I will check if that works. When it will be officially released? With all certificates etc?


Ok, now it works. My last question. Are attaching USB devices should work in this release or not (for me it not work, and in reports from that topic I also see that people writing about that but some time ago - then most posts is about how the documentation should be updated)?

1 Like

USB and audio support do not related with QWT. It can be enabled via dom0 commands:

qvm-features [windows-qube] stubdom-qrexec 1
qvm-features [windows-qube] audio-model ich6

THX. I added this options to VM. But USB still not working. Can this be related to version of USB? On Virtualbox there was separate drivers for USB 3.0.


Also I want to ask about Xen Network driver. I installed it and then network stop working. So I simply uninstall that device from device manager, and Internet are back. But aren’t the Xen driver better?

Did you reboot VM? Emulated USB NEC controller should appears in Device Manager.

The performance with Xen network drivers is better, but there are issues with DHCP. We placed script (qnetwork_setup.bat) to manual assign IP address and it is enough to setup standalone VM, but not enough to use with template based VM.

Yes, I restarted the VM, also added repos from that post, update dom0 and reboot qubes.

Don’t have such a device in DM. Now the error is different

That is not necessary since all packages already in stable repos.

Could you place output from qvm-features [win-qube] ?

I have a typo in one of the features that @jevank figured out on pm. So for now everything seems to work.