Can't link USB keyboard after doing sys-usb

So I was able to get into my qubes even though I forgot to enable keyboard once I did my sys-usb.
Think PS/2.
I am typing the command in dom0 so that USB keyboard will work which is this…
sudo qubesctl state.sls qvm. sys-keyboard
I hit enter and dom0 gives me this…

[ERROR ] Template was not specified incorrectly : False

local :
Data failed to compile:

No matching sls found for ‘qvm.sys-keyboard’ in env ‘base’
DOM0 configuration failed, not continuing

I even ran
sudo qubes -dom0-update.

Still same error

HELP!!!

I fixed my problem, “go me”"

Windows has crippled me…

How much farther do I have to go down the "rabit hole’??? …LOL

If I may ask, what was the solution?

I use what was stated in the docs I was finging which is this…
sudo qubesctl state.sls qvm.sys-keyboard

And that didn’t work usb keyboard was stilled locked out. So I was using a PS/2 keyboard to log-in to my Qubes and type everything .
Did another dom0 update just too make sure all was good still no usb keyboard…

Upon days of digging and reading I came across a qubes old doc that stated the same command but only a slight change …
sudo qubesctl state.sls qvm.usb-keyboard…

It worked after rebooting and the USB keyboard
has been working since and my (sys-usb) is running awesome!!

thank god my old PS/2 kwyboard was around!!!

1 Like