Can't Launch Application from Qubes Menu

If I try to launch Authenticator from the Dom0 Menu Bar, the associated AppVM starts successfully but Authenticator does not launch. I can only launch it from the AppVM’s terminal. Is this normal?

This may be an issue with the application itself.

Here the issue is probably not specific to Qubes OS, but rather some issue with the authenticator package.

Can you post the command you’re using and the .desktop file for authenticator in /usr/share/applications/ (right after Exec=)?

Note: I’ve tried to generalize a bit the title since this may happen from time to time. @jpbaiocchi feel free to ajust it if you feel it doesn’t properly reflect your issue.

user@brave:~$ authenticator
[ERROR] 2022-06-26 23:32:33 Could not read the secret code,the keyring keys were           reset manually

There does not appear to be a .desktop file for authenticator in the specified directory. Application seems to be stuck in an indefinite “loading process” until exited.

In order for it to show up in the menu, there must be one

user@clearnet:/usr/share/applications$ ls -l
total 312
-rw-r--r-- 1 root root  3417 Feb 26  2021 assistant-qt5.desktop
-rw-r--r-- 1 root root  2322 May 26  2021 audacity.desktop
-rw-r--r-- 1 root root  8563 Jun 24 01:00 brave-browser.desktop
-rw-r--r-- 1 root root  1721 Sep 28  2020 com.github.bilelmoussaoui.Authenticator.desktop
...
user@clearnet:/usr/share/applications$ cat com.github.bilelmoussaoui.Authenticator.desktop
[Desktop Entry]
Name[ar]=الموثق
Name[ca]=Authenticator
Name[da]=TofaktorAutentifikation
Name[de]=Zweifaktor-Authentifizierung
Name[es]=Authenticator
Name[fi]=Todennin
Name[fr]=Authentificateur
Name[hu]=Hitelesítő
Name[id]=AutentiksiDuaFaktor
Name[it]=Authenticator
Name[ko]=인증기
Name[nb]=Authenticator
Name[nl]=Authenticator
Name[pl]=Authenticator
Name[pt]=Authenticator
Name[pt_BR]=Autenticador
Name[ru]=Аутентификатор
Name[sr]=Аутентификатор
Name[sr@latin]=Autentifikator
Name[sv]=Authenticator
Name[tr]=Kimlik Doğrulayıcı
Name=Authenticator
GenericName[pl]=Uwierzytelnianie dwuetapowe
GenericName[pt_BR]=Autenticação de dois fatores
GenericName=Two-factor Authentication
Comment[pl]=Program do uwierzytelniania dwuetapowego
Comment[pt_BR]=Um aplicativo de autenticação de dois fatores
Comment=A Two-Factor Authentication application
Type=Application
Exec=authenticator
Terminal=false
Categories=GNOME;GTK;Security;Utility;
Keywords[es]=Gnome;GTK;Autenticación;Verificación;2FA;Factores;Pasos;
Keywords[fi]=Gnome;GTK;Verification;2FA;Authentication;TwoFactor;tunnistaminen;vahvistus;kaksivaiheinen;todentaminen;
Keywords[hu]=GNOME;GTK;Ellenőrzés;2FA;Hitelesítés;Kétlépcsős;
Keywords[pl]=GNOME;GTK;Weryfikacja;2FA;Uwierzytelnianie;Upoważnianie;Autentykacja;Dwuetapowe;Dwuskładnikowe;TwoFactor;
Keywords[pt_BR]=Gnome;GTK;Verificação;2FA;Autenticação;Authentication;TwoFactor;Dois Fatores;
Keywords=Gnome;GTK;Verification;2FA;Authentication;TwoFactor;
# Translators: Do NOT translate or transliterate this text (this is an icon file name)!
Icon=com.github.bilelmoussaoui.Authenticator
StartupNotify=true
StartupWMClass=com.github.bilelmoussaoui.Authenticator

Weird. It only has there authenticator in the Exec= parameter. Could it be that it needs the full path the the application. Like /usr/bin/authenticator? Try replacing it with the full path, which you can obtain by typing on the terminal which authenticator. (the command which tells you the location of any program)