Can't install debian-10-minimal

I have previously tried to install debian-10-minimal with

sudo qubes-dom0-update qubes-template-debian-10-minimal

but I didn’t have enough RAM during the “setting-up” of the new template so it had no apps. It may even be broken, I didn’t check. So seeing how it’s broken I ran:

qvm-prefs debian-10-minimal installed_by_rpm false

and removed the template using the Qube Manager.

Now I’m trying to install it again but I’m getting

No match for argument qubes-template-debian-10-minimal
Nothing to download

I normally use sys-whonix for dom0 updates but to troubleshoot I changed it to sys-firewall and now I’m getting

bash: /usr/lib/ No such file or directory

How do I fix this?

Not sure on your first issue. Maybe try:

sudo qubes-dom0-update --clean qubes-template-debian-10-minimal

Can you verify in /etc/yum.repos.d/qubes-templates.repo that it has enabled = 1 for the [qubes-templates-itl] section?

Your second issue, is your sys-firewall a minimal template? Do you have qubes-core-agent-dom0-updates installed?

1 Like

Does anything happen if you do sudo dnf remove qubes-template-debian-10-minimal in dom0?

@adw I’m getting

Dependencies resolved.
 Package                     Arch   Version            Repository          Size
                             noarch 4.0.1-201912251612 @qubes-dom0-cached 986 M

Transaction Summary
Remove  1 Package

Installed size: 986 M
Is this ok [y/N]: y
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
usage: qvm-template-postprocess [--verbose] [--quiet] [--help] [--really]
                                [--skip-start] [--keep-source]
                                {post-install,pre-remove} name dir
qvm-template-postprocess: error: No Qube with this name exists
error: %preun(qubes-template-debian-10-minimal-4.0.1-201912251612.noarch) scriptlet failed, exit status 2
Error in PREUN scriptlet in rpm package qubes-template-debian-10-minimal
Error in PREUN scriptlet in rpm package qubes-template-debian-10-minimal
qubes-template-debian-10-minimal-4.0.1-201912251612.noarch was supposed to be removed but is not!
  Verifying   : qubes-template-debian-10-minimal-4.0.1-201912251612.noarc   1/1 

  qubes-template-debian-10-minimal.noarch 4.0.1-201912251612                    


When I run sudo dnf remove qubes-template-debian-10-minimal

The first command didn’t work. enabled = 1 is there. And I totally forgot to install qubes-core-agent-dom0-updates. Thank you!

Do you still have the original problem now, after doing this?

Unfortunately, I do.

@santorihelix Can you post the full output of:

rpm -qa qubes-template-debian\*
sudo dnf install qubes-template-debian-10-minimal
1 Like

Thanks a lot @icequbes1 but I seem to have fixed my problem. Sorry for forgetting to update.

For anyone who’ll have this issue in the future, I solved it by

sudo qubes-dom0-update --action=reinstall qubes-template-debian-10-minimal

as per the Official Qubes Docs. (:man_facepalming: )

Glad you resolved @santorihelix. I coincidentally experienced this exact issue today after running out of disk space during template install!

While those docs do mention to use reinstall, there is still some bugs/improvements that can be made, see this issue:

The reason you originally received “No match for argument qubes-template-debian-10-minimal” is because the package is still installed according to rpm. You can’t see it, but qubes-dom0-update runs dnf install --exclude=qubes-template-debian-10-minimal which makes the package invisible even if you specified it on the command line.

1 Like

Thanks for the link @icequbes1

  • Oh, good to know. I thought my sin was trying to delete the VM from Qube Manager. Thanks again.

Oh no, for you have still sinned by removing a dnf-installed template using Qubes Manager. By doing this, you have prevented the template from being uninstalled properly by dnf.

However, there should be more done by Qubes OS to prevent you from believing this is the way to remove the template (user experience).

Once you try to remove the template from Qubes Manager and receive “error: template installed by package manager”, this should happen:

# user: "ok, I'll use the package manager"
sudo dnf remove qubes-template-debian-10-minimal

Instead of:

# user: "Is that so???? Watch this!" 
qvm-prefs --set debian-10-minimal installed_by_rpm False
qvm-remove debian-10-minimal
1 Like

Oh so in the docs the important part was

Try the normal method before resorting to this.

I just continued without even clicking that link. Thank you so much for your help and clearing my delusions @icequbes1!