Can't get Qubes to boot on Clevo laptop

I hope you are all having a good day.

I recently managed to get myself a new Clevo laptop and I have run into some issues trying to get Qubes to boot, which led me to wonder if the hardware is supported. I know Qubes has a narrow range of support for hardware, and my laptop does not show up in the HCL. I would still like to try and get Qubes working, and I don’t mind a good challenge! Could the following system specs possibly support Qubes?


  • Intel Core i7-1165G7
  • Intel Iris Xe Graphics
  • 32 GB RAM
  • 1 TB SSD


  • Insyde H2O BIOS Version:1.07.06

Things tried so far:
I have made sure to verify the signature of the Qubes image. I’ve created the bootable USB both with BalenaEtcher and the dd command provided on the site:

sudo dd if=Qubes-RX-x86_64.iso of=/dev/sdY status=progress bs=1048576 && sync

When trying to boot from USB, no boot screen is presented and I am not able to change boot options. All advice is welcome, thank you in advance!

What iso images have you tried?

I advise trying to install Qubes 4.1 (if you haven’t already)

You can also build isos, (though the iso-builder works out-of-the-box about 1% of the time, and atm is a pain because of an RPM issue):

1 Like

Thanks for your advice! I haven’t tried Qubes 4.1 yet! I’ll make sure to give that a go as well, that has me hopeful :slight_smile:

After looking into it some more I suspect it could also be the BIOS so if the images don’t work, I could look into replacing it with the open source BIOS that system 76 uses

Thank you again, I’ll let you know if it works

1 Like

Are you using a legacy bios and a UEFI bio, you can try to switch from one to an other if you can and start to boot again

There is a Dell XPS 13 9310 with a HCL report that shares your
CPU and therefore chipset and graphics:

It needs i915.alpha_support=1

The corresponding thread starts off with:

I found it very difficult to get Qubes installed and usable. These
are some notes I made at the time and may need some adjustment for
other scenarios.

It contains specific instruction on how to prepare the install media,
these will likely help you get Qubes OS installed.

1 Like

And to cover all bases, are you sure you are hitting the right key to get into the BIOS and/or boot menu to select a different boot device?

1 Like

Yup, the menu pops up successfully and I am able to select the USB

Insyde H2O BIOS is proprietary, so that might be causing issues as well. I’ll try to change the boot settings first and if that doesn’t work, try to switch to the BIOS of System 76 for the laptop

1 Like

Hello Sven,

Thank you for your detailed and specific reply! I have tried this approach but I have run into some problems.

I have tried setting up the Qubes Builder on Fedora 34, following the steps described here: qubes-builder.
Everything works like a charm up until make qubes, when I get the following error:

home/username/qubes-builder/qubes-src/builder-rpm/chroot-dom0-fc32/var/lib/rpm/.rpm.lock (permission denied)

I have changed the /etc/sudoers file by adding the following line so sudo root works without any prompt

username ALL=(ALL) ALL

I know there is a known bug in RPM at the moment, linked by Quser59: issue 6522, but this doesn’t seem to completely describe my error. Do you have a suggestion on how to proceed?

Kind regards and thank you in advance!

Thank you for your detailed and specific reply! I have tried this
approach but I have run into some problems.

Can you be a bit more specific? Have you been able to install Qubes OS
with the modified install media?

I have tried setting up the Qubes Builder on Fedora 34,

I don’t quite see how you get from our discussion to setting up a Qubes
Builder. If it’s unrelated, please start a new topic.

Hello Sven,

I’m afraid I misunderstood what you meant in your original post. When I tried modifying the iso file, I got an error saying the partition table was missing and it wouldn’t result in a valid bootable USB, so I assumed I had to go through the build process. Thank you for pointing me in the right direction

1 Like