Can't access external hard drive connected through USB

This is likely a user error, but I’m stuck, hoping somebody can help.

I connected the hard drive through USB. There is no other USB device connected at the moment.
Using Qubes UI (top right corner), I attached the “sys-usb:3-1.2 Western Digital…” to my “bitcoin” domain.

Now, I would expect, this hard drive to show when I do ls /mnt/ or ls /media (in a Terminal in bitcoin AppVM), but it’s not there. Following docs, I tried to mount it with sudo mount /dev/... ~/mnt, but I don’t see any /dev/xvdi-prefixed devices, only these:

% ls /dev/xvd* 
  /dev/xvda   /dev/xvda2  /dev/xvdb  /dev/xvdc1  /dev/xvdd
  /dev/xvda1  /dev/xvda3  /dev/xvdc  /dev/xvdc3

I don’t see the hard drive in Files GUI either.

Is there something else I need to do?

Thank you.

Hi @crowphale! Welcome to the forum \o/

I’ve seen disks listed as /dev/sda before (not sure why, though). Can you see it?

Also, try doing lsblk on the AppVM to list the block devices before and attaching to the Qube to see if anything changes.

If you attach a volume it will appear as /dev/xvdi.. etc.
If you attach a USB device it will be treated as normal by OS and appear as
/dev/sda etc

1 Like

Thank you for the quick responses! The output of lsblk is the same before and after attaching the disk to “bitcoin” domain. Here is the output:

% lsblk
NAME    MAJ:MIN RM  SIZE RO TYPE MOUNTPOINT
xvda    202:0    1   10G  0 disk 
├─xvda1 202:1    1  200M  0 part 
├─xvda2 202:2    1    2M  0 part 
└─xvda3 202:3    1  9.8G  0 part /
xvdb    202:16   1   10G  0 disk /rw
xvdc    202:32   1   10G  0 disk 
├─xvdc1 202:33   1    1G  0 part [SWAP]
└─xvdc3 202:35   1    9G  0 part 
xvdd    202:48   1  500M  1 disk 

I don’t see /dev/sda unfortunately.

Here is the output of qvm-usb (run in dom0 terminal):

BACKEND:DEVID  DESCRIPTION                                             USED BY
sys-usb:3-1.2  Western_Digital_Elements_2621_575841324136304635394C59  bitcoin
sys-usb:3-1.4  Broadcom_Corp_BCM20702A0_2CD05A805E08                   
sys-usb:3-1.6  Chicony_Electronics_Co.__Ltd._Integrated_Camera 

Another thing I noticed: in the bitcoin AppVM/Qube settings, under “Devices” tab, there are 3 “USB…” devices. Do I need to enable any of those?
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipse

I’m surprised that there are 3 of these, since my laptop only has 2 USB ports. Also, when I enable those (move them to the right list), there is a red label saying “You’ve enabled dynamic memory balancing, some devices might not work!”. Does anyone know what that these “devices” are and what this red label means?

1 Like

I’m surprised that there are 3 of these, since my laptop only has 2 USB ports. Also, when I enable those (move them to the right list), there is a red label saying “You’ve enabled dynamic memory balancing, some devices might not work!”. Does anyone know what that these “devices” are and what this red label means?

I’m not sure exactly what these devices are, but I have had a lot of
trouble with USB passthrough of storage devices. Passing the block
device seems to work fine though.

Try using qvm-block instead. When you don’t need the USB protocol
directly, it seems to be far more stable.

You didnt say that you had assigned USB controllers to the bitcoin qube.
I wouldn’t do that.
Or are these 3 devices?

What does lsusb show before you attach the storage device, and then after?

This is weird. Today, suddenly things are different: when I plug in the external disk through the same USB port as yesterday, it also shows “sys-usb:sda” and “sys-usb:sda1” in the GUI (top right corner), in addition to the “sys-usb:3-1.2 Western Digital…” (which were there yesterday).

And when I attach “sys-usb:sda”, then I see the external disk in Files GUI, as well as /dev/xvdi as well as /dev/xvdi1. In other words, it’s all working.

I wish I knew what changed from yesterday.

1 Like