Cannot install Windows 7/10 because of qube termination

I’m trying to install Win 7 and 10 but unfortunately the qube is terminated automatically even the installation process is not finished.
How can I force to not close the qube in order to be able to finish the installation process?

Using HVM, created via UI in Qube Manager.
Tested via CLI based on the documentation but having same problem

Set qvm-features <VMname> qrexec "" to stop Qubes expecting to connect to the qrxec daemon. You could also increase the time limit for Qubes to find the qrexec connection, by qvm-prefs qrexec_timeout 600.

For a more detailed description, see Windows qubes.

Unfortunately my windows-10 qube still terminated automatically and the installation was only at 7%.

Increased timeout to 1000 and qrexec ""

Two of the 4 logs founded are saying:

Icon size: 128x128
domain dead
Failed to connect to gui-agent

domain dead
cannot connect to qrexec agent: No such file or directory

And from the .log file [/var/log/xen/console/qube-name.log]

In some cases useful info is found in syslog - try
       dmesg | tail or so.
Waiting for /dev/xvdd device...
mount: /dev/xvdd is write-protected, mounting read-only
[    1.654725] EXT4-fs (xvdd): mounting ext3 file system using the ext4 subsystem
[    1.656414] EXT4-fs (xvdd): mounted filesystem with ordered data mode. Opts: (null)
mount: mount point /sysroot/lib/modules does not exist
mount: /sysroot not mounted or bad option

       In some cases useful info is found in syslog - try
       dmesg | tail or so.
switch_root: failed to mount moving /sysroot to /: Invalid argument
switch_root: failed. Sorry.
[    1.666396] Kernel panic - not syncing: Attempted to kill init! exitcode=0x00000100

After some searches I ended up looking inside
/var/log/xen/console/hypervisor.log and it seems there was an error about low memory.
Increased from 4Gb to 8Gb and that worked. Don’t understand why 4Gb wasn’t enough but the problem has been solved.
Thank you

1 Like