Cannot boot R4.1 after installing R4.2 on external ssd

R4.1 is installed on internal ssd. UEFI boot menu does show Qubes OS as well as the internal disk.
Selecting Qubes OS returns to the Uefi boot menu.
Selecting the internal disk I am not seeing a failure message but the grub command line.
On the grub cmd line entering configfile (hd0,gpt1)/ offers efi/ and startup.nsh.
Selecting efi offers boot/ fedora/ qubes/.

selecting boot/ only has bootx64.efi
selecting fedora returns to grub cmdline
selecting qubes offers xen.efi , xen-4.14.6.efi, fonts/, grub.cfg, various initramfs-5*.img, some initramfs-6*.img

Selecting latest linux and initrd from (hd0,gpt2) and boot failed with root-switch error even though the luks password has been asked and given.

Pls help

Did you try to boot like this?

You can also try to boot from another Qubes OS or from Qubes OS installer and check/fix your EFI entries using efibootmgr tool.

No success using configfile (hd0,gpt1)/EFI/qubes/grub.cfg which returned me to grub cmd line.

You can try to fix boot entry like this:

adding an entry to boot menu failed as well. Tried
efibootmgr -v -c -u -L “Qubes OS R4.1” -l /EFI/qubes/grubx64.efi -d /dev/sda -p 1
Tried rescue from R4.2, selected 1) Continue, entered passphrase resulted in You don’t have any Linux partitions. However lsblk -o +fstype,fssize,label displayed 3 partitions on sda.

Did you check that /dev/sda1 is EFI System type partition?
You can also mount the /boot and /boot/efi partitions and check the grub configs there. Maybe the grub files are corrupted.
Check this file on EFI System partition (/dev/sda1 ?):
And this file on /boot partitions (/dev/sda2 ?):

According lsblk -o +fstype, parttype,parttypename /dev/sda1 is indeed an EFI System type partition
No grub.cfg in /dev/sda2/grub2/ but grubenv and themes.
There are grub.cfg, and grubx64.efi. Figured uuid or partuuid of sda2+3 should be in grub.cfg. Turned out to not be the case. However uuid+partuuid can be found in grub.cfg.rpmsave.

Can you compare the IDs in the grub.cfg to the IDs of the Qubes OS 4.2 install on external SSD?
Maybe the GRUB config from external Qubes OS 4.2 installed on external SSD was installed on your Qubes OS 4.1. partition for some reason.

You can save a copy of grub.cfg just in case and then replace grub.cfg with grub.cfg.rpmsave. And try to boot your Qubes OS 4.1.

Copying grub.cfg.rpmsave → grub.cfg resulted in 2 successfully boots into Qubes OS 4.1.
Now I need to find out which efibootmgr entry is used.
Thanks a lot for your help.