Cannot boot after upgrading kernel to 5.15 from 5.10

I recently upgraded dom0 to the latest kernel (5.15) but it wouldn’t boot. I Just get a blank screen after the grub splash.

I then tried selecting the older kernel (5.10.112 I think it was), and that booted fine.

I waited a bit until today and figured I’d see if there was a kernel update and there was. I updated via cli with “sudo dom0-qubes-update”. After the update completed (was getting ready to reboot), I started seeing some odd artifacts in the main menu, lines between entries as I moved around. Hmm. Then my system stopped responding and the screen shut off. Ruh roh. Tried a power cycle and now all I get is the grub menu.

I thought I remembered there being a "rescue qubes installation option in the install image, so that’s going to be my next step.

Any ideas what happened or what direction I should be heading in? This isn’t my daily driver, so this is mostly just annoying and I’ve got backups, but I was about to get back to using it more heavily, so I’d like to fix it rather than wipe/reinstall. And more to learn this way.


Rescue failed. “You don’t have any Linux partitions. Rebooting.”

I tried the shell and see partitions. Mounted the boot partition and poked around.

Got an error when trying to cat /mnt/p1/EFI/qubes/grub.cfg;
“cat: grub.cfg: Input/output error”

Other files in the directory show fine. Also, there’s no new kernel img. Only the last two (5.10.112 and 5.10.90). so… it seems like my previous upgrade failed to correctly install the 5.15 image, hence the black screen when booting that kernel, but choosing 5.10.112 working ok.

Still investigating.