Can not boot from USB

I’ve installed Qubes installer on USB using rufus on factory reset windows 11 laptop. All my BIOS setting has been changed to what Qubes recommends. I installed Qubes with installer USB on another large and fast USB 3.0. Everything works fine and I can login to my profile and use Qubes however I want. But as soon as I log out, shut down and remove the USB, I cannot boot from it again. I shut down insert USB and go to BIOS but the USB is not in the boot from list even though I was able to boot from it after installation. Why cant I boot from the USB even though I have other OS USBs that boot just fine?

My guess is this:

  • During install, the installer adds UEFI boot entry for the USB stick to the list in the BIOS
  • When the BIOS starts, it checks the UEFI boot entries, and remove any it finds missing

I’ve not tested it myself, but you could try the suggestion from:

Hey, i have the same problem. Do you solve it? I have been trying for 3 days…

Can/will you share a bit more details about how your hardware/configuration is and what you’ve tried?

It’s the same for me as for the main questioner: I can install everything without any problems and then I’m in Qubes OS. However, if I shut down Qubes OS, remove the stick, then put the stick in my laptop at a later point in time and want to boot, my stick is no longer displayed.

At first I thought it was Rufus, so I tried Ventoy. Now I have seen that many have the same problem.

I also adjusted the BIOS and UEFI settings as recommended.

I’ve read several times now that this post should help: uefi - "EFI\boot\bootx64.efi" vs "EFI\ubuntu\grubx64.efi" vs "/boot/grub/x86_64-efi/grub.efi" vs "C:\Windows\Boot\EFI\*" - Unix & Linux Stack Exchange x86-64-efi-gru/571173#571173

However, I can’t do anything with it because I’m not very familiar with the IT field. It was also said under one post that you should select “Select an UEFI file as trusted for executing” in the UEFI settings and then specify Qubes there. I don’t have that attitude either.

Then I thought it was my USB stick and bought an extra ssd, that didn’t help either.

I almost despair.

Copy files from /boot/efi/EFI/qubes to /boot/efi/EFI/BOOT and in /boot/efi/EFI/BOOT change filenames grubx64.efi → BOOTX64.efi and grub.cfg → BOOTX64.cfg

Hi, as I said, I’m not very familiar with it. I’m supposed to do this for my little brother. Where exactly can I find these files?

Boot from another system for example from Qubes OS installer USB disk.
Find out on which disk did you install Qubes OS:
fdisk -l
For example it’s /dev/sda.
Find out which partition on /dev/sda has EFI System type:
fdisk -l /dev/sda
For example it’s /dev/sda1.
Mount EFI partition:
mount /dev/sda1 /mnt
Copy files from /mnt/EFI/qubes/ to /mnt/EFI/BOOT/:
cp -r /mnt/EFI/qubes/* /mnt/EFI/BOOT/.
Change filenames grubx64.efi → BOOTX64.efi and grub.cfg → BOOTX64.cfg:
mv /mnt/EFI/BOOT/grubx64.efi /mnt/EFI/BOOT/BOOTX64.efi
mv /mnt/EFI/BOOT/grub.cfg /mnt/EFI/BOOT/BOOTX64.cfg

I’m sorry, that’s too complicated for me. Are there no other options?

Or are there video tutorials for it?

If you’re not familiar with Linux then you can do this in Windows as well.
If you have Windows installed on another disk or you can connect disk with installed Qubes OS to another PC with Windows then in Windows you’ll be able to see this EFI partition from Qibes OS disk and change files on it.