Bootproblem on iMac 5K

Hello forum users,
I’m trying to install QubeOS on an iMac 5K. It is physically in an Intel Core i5 with AMD graphics card. After the installation, which runs without any problems, I get the following image after the loading sequence. I’m trying to boot from a USB SSD.

Does anyone know this problem?

Best regards

Hi @mrmacintosh,

Welcome to the forum!

Any chance you could give us the model number of your iMac (“A” followed by a number)?

Or the output of lspci?

That hardware is actually pretty decent.

So, you able to install Qubes OS successfully and reboot, right? Just checking…

So, when you press the power button and turn the machine on, this happens:

  1. You press the power button
  2. The machine goes “DUUUUNNGGG!” (Apple’s inamous “everything is working properly” noise)
  3. Your screen turns on and goes white/grey
  4. Your screen then shows the boot drive selection screen (I’m assuming you’re holding down the Alt/Option key because you’re booting from a USB drive)
  5. You select Qubes OS
  6. The GRUB menu shows up
  7. The kernel and initramfs loads
  8. Your screen then shows that psychedelic fractal pattern that you took a photo of

How much of this is accurate?

Hello alzer89,

the installation runs smoothly. The system then reboots and I come to an initial setup menu (see image).

I confirm this and the templates/VM are started to be set up. To the point that the network is set up. And then the Mac crashes and reboots.

After booting, I only see a mouse cursor and the system no longer responds. If I install the system and don’t have any templates set up. Runs the configuration clean and the system boots. Network or Internet is then not available. I only see the “localhost” via “ip a”. So it seems to have something to do with the network setup.

Other Linux systems, such as Archlinux, run without problems.

Best regards

Your Broadcom wifi card is giving you grief.

Check the HCL for what to do with other Apple hardware models.

I’ll write up some instructions in a few hours for your model.

…and here they are :slight_smile:

I’m assuming you’re fairly savvy with the terminal. If not, ask for clarification :slight_smile:

  1. Boot from ISO and install Qubes OS normally
  2. When it has finished installing, DO NOT REBOOT.
  3. Press Ctrl + Alt + F2 to go to tty2
  4. Type in the following command: chroot /mnt/sysimage
  5. Create the following config file (using vim/nano/emacs) at: /usr/local/bin/fix-wifi.sh:
#!/bin/sh

# Comment this out AFTER first boot
echo 1 > /sys/bus/pci/devices/0000\:03\:00.0/remove

# Uncomment these AFTER first boot
#echo 03:00.0 > /sys/bus/pci/drivers/pciback/permissive
#echo 03:00.0 > /sys/bus/pci/drivers/pciback/allow_interprupt_control
#echo 1 > /sys/bus/pci/devices/0000\:03\:00.0/d3cold_allowed
#echo pciback > /sys/bus/pci/drivers/pciback/0000\:03\:00.0/driver_override
#echo 1 > /sys/bus/pci/drivers/pciback/0000\:03\:00.0/reset
#echo 1 > /sys/bus/pci/drivers/pciback/0000\:03\:00.0/rescan
  1. Make sure /usr/local/bin/fix-wifi.sh is executable:
chmod +x /usr/local/bin/fix-wifi.sh
  1. Create the following config file at /etc/systemd/system/fix-wifi.service:
[Unit]
Description=Reset Broadcom Wifi Card

[Service]
ExecStart=/usr/local/bin/fix-wifi.sh

[Install]
WantedBy=multi-user.target
  1. Enable the systemd service you just created:
systemctl enable fix-wifi.service
  1. Reboot
  2. Go through the first boot setup as normal
  3. Once you have your default Qubes set up, change /usr/local/bin/fix-wifi.sh to look like this:
#!/bin/sh

# Comment this out AFTER first boot
#echo 1 > /sys/bus/pci/devices/0000\:03\:00.0/remove

# Uncomment these AFTER first boot
echo 03:00.0 > /sys/bus/pci/drivers/pciback/permissive
echo 03:00.0 > /sys/bus/pci/drivers/pciback/allow_interprupt_control
echo 1 > /sys/bus/pci/devices/0000\:03\:00.0/d3cold_allowed
echo pciback > /sys/bus/pci/drivers/pciback/0000\:03\:00.0/driver_override
echo 1 > /sys/bus/pci/drivers/pciback/0000\:03\:00.0/reset
echo 1 > /sys/bus/pci/drivers/pciback/0000\:03\:00.0/rescan
  1. Reboot once more (so that the kernel doesn’t ignore your wifi card)

This is where we’re entering unknown territory. I have tried this on several Apple models, and have had mixed results.


  1. Open up your sys-net Qube Settings
  2. Select the Devices tab
  3. Add Pci device 03:00.0 to sys-net
  4. Start the sys-net qube

This is where 3 possible things will happen

  1. Your machine completely freezes, and you’ll have to hold down the power button and hard-reboot. Your wifi card will be unusable for now, but at least you have your Qubes install…and I will help you try and get the Broadcom wifi card working :slight_smile:
  2. sys-net starts, but your wifi card is undetected. This is better than nothing. This means you’ll need to install the proprietary broadcom firmware from the RPMFusion repository inside sys-net (or if your sys-net is disposable, the Fedora template that your sys-net is based on)
  3. sys-net starts and your wifi card just magically works. Happy days!

Hopefully this helps. Let me know how it goes :slight_smile:

Hello Alzer89,

Thanks for the detailed help. Have tried everything so far. Unfortunately, after the installation (Qube configuration), I can no longer get into tty2. I got it working now. I had previously got version 4.0.3 to run.

But there seems to be a problem with the WLAN card and the Ethernet card. These cannot be used in 4.03 and 4.1.1 (see image). I don’t need the Wifi card at all either, the iMac is connected to an Ethernet cable.

Does it make sense to continue playing around with the Mac hardware or is it easier to buy a USB3 to Ethernet adapter?

Link: Amazon.de

If I now want to block the wifi card and the network card, then it should be enough if I use the first line of wifi-fix.sh and add another one, right?

echo 1 > /sys/bus/pci/devices/0000\:03\:00.0\remove
echo 1 > /sys/bus/pci/devices/0000\:04\:00.0\remove

Best regards
David

Not true. They can be used, but with the right configuration and firmware (and neutering of Apple’s incredibly invasive EFI bootloader).

For this, open sys-net Qube Settings → Devices, and set no hard reset for 04:00.0 (assuming your ethernet NIC).

That should make it work.

Apple hardware is at a unique place in the hardware spectrum. On one hand, they only really release one or two configurations of their hardware, so once you’ve worked out the kinks for a particular model, you can be safe to assume that it’ll apply across the board.

But on the other hand, their hardware is often custom-designed in collaboration with hardware manufacturers specifically for Apple, and sometimes identical hardware components get completely different firmware.

Oh, and Apple seemed to have a fetish for Broadcom stuff, and in the past, nVIDIA. The most “diplomatic” way I can say it, is that these two companies “don’t particularly like Tux and the Wildebeest” (they hate FOSS).

Thankfully, both companies’ older hardware have a minimum baseline of mainline Linux kernel support, but the Wifi cards are a different story. It can be done, though, so don’t get discouraged :slight_smile:

Meanwhile, a USB ethernet adapter wouldn’t really solve much, but you’re more than welcome to try. You’ll need to create your own USB qube, as it’s likely that the installer didn’t set one up for you automatically. There are a million and one guides on how to do this on this forum, and we can guide you through that if you get stuck.

Correct, but there’s no need to do that. At least not yet :slight_smile: