Boot to previous Kernel gives "no multiboot header" error

In trying to troubleshoot sleep/suspend issue I installed kernel-latest. On reboot it appears to panic at disk encryption. I am trying to boot to old kernel and get “no multiboot header” error.

Hope someone can help.

Update: I made some progress getting atleast booted to the old kernel but it looks like I need a switch for designating a “root”. It drops out with [failed] Failed to start Switch root

I tried
grub> set root=(hd0,2)
grub> linux /vmlinux-5.10.76-1.fc32.qubes.x86_64
grub> initrd /initramfs-5.10.76-1.fc32.qubes.x86_64
grub> boot

I get the disk encryption dialog, enter PW then the Failed to start Switch Root

Please any help would be great.

Edit2 I think I found what I needed. Entered:

This got me in but mosts service VM would not start.

I backed up and previously I had chosen the “advanced options…” and the “Xen …config” which erored with the “no multiboot” error. This time I tried just selecting the Xen…OS and it seems to boot fine.

So to clarify, to boot previous kernel, choose option 2 at Grub and then option 1 and then the kernel version.