Boot fails: Nouveau 0000:01:00:0: fifo: SCHED_ERROR 20 []

I have been using Qubes for a couple of days on this install. Today I tried to boot but, after getting past the disk decrypt, and loading my VMs, the boot complains about this problem, about a million times, and reboots after some more boot dialogue.

I managed to get into a command console with ctrl alt F2 and log in with my user credentials. That is how I can see this error is repeated so many times (in “sudo dmesg”).

The last thing I did before shutting down was to install the fedora 32 template. Apart from that I installed the 5.10 kernel for VMs, and set this as the kernel for sys-net, the fedora 30 kernel, my stand alone mail template.

I see that dom0 is now operating with kernel 5.4.88-1.qubes.x86_64

Does anyone have any suggestions how to recover my installation?

Problem solved. I followed these instructions to switch dom0 back to an earlier kernel and the system booted up again.

sudo nano /boot/efi/EFI/qubes/xen.cfg

In the `[global]` section at the top, change the `default=` line to match one of the three boot entries listed below. For example,