Boot device not recognized / troubleshooting instructions question

Qubes OS Troubleshooting no boot device

I just built a PC for Qubes, and after the installation process went great, the computer just booted to the UEFI BIOS setup instead of Qubes. I found the troubleshooting section above that seems to apply, but I had a few extra questions as a new user. The problem seems to be that my BIOS does not recognize the Qubes partition as bootable.

Quick note, I am quite surprised that this system has this issue as I used identical motherboard and parts to certified hardware specifically this system trying to avoid problems like this one–

The Dasharo FidelisGuard Z690 is a desktop based on the MSI PRO Z690-A DDR4 motherboard.

I have determined that I have a system that does not recognize the UEFI EFI that Qubes uses and ignores it as a boot option. I thought it might be the nvme, but installing ubuntu on it boots.

I can’t follow the troubleshooting instructions because from the rescue shell, even if it is decrypted with my passphrase or if I install Qubes without an encrypted LVM LUKS, it still says, “You have no Linux partitions”.

I can’t get to the /boot/efi/EFI/qubes because any partition I can mount using Ubuntu has an empty boot directory. I have tried the “How to mount a Qubes partition from another OS,” and still, I keep hitting a wall. I actually put a spinning disk in and installed Ubuntu on that, hoping I could get into the partitions I couldn’t get from the rescue shell, but I couldn’t find the pertinent boot folder.

Please keep in mind I still have never seen Qubes past the install screen, so I don’t know much about the partitioning and where to find what, and the troubleshooting doesn’t specify much in my case. Kinda pulling my hair out because I built this PC just for Qubes after my other system had hardware issues and couldn’t even get to the install screen.

Thanks in advance for any help at all. I hope I was descriptive enough, if more information would help just let me know. I really love the idea of this OS and would love to use it!

Edit: I can’t use CSM or Legacy boot mode because the integrated graphics mode does not allow it on my Intel chip, so I am stuck with UEFI mode.
nvme0n1p1 = EFI partition
nvme0n1p2 = ext4
nvme0n1p3 = lvm

Which of these partitions do I need to mount and change the EFI files on, and can it be done from the rescue shell somehow? I have tried following old posts to resolve this, and I am still not even sure this is my actual issue. Sorry for the long-winded post.

screenshot of my partitions after non-ecrypted LUKS installation:

Did you try to mount /dev/nvme0n1p1? Is it empty?
If it’s not empty then you can try to add EFI boot menu entry using this command in Ubuntu or in Qubes OS installer shell:

efibootmgr -v -c -u -L "Qubes OS" -l /EFI/qubes/grubx64.efi -d /dev/nvme0n1 -p 1

If it won’t work then you can try this:

1 Like

Hi Crowizz

To just test your installation, you could try to find the boot partition from the USB-installer:

it might be

  • (hd0,gpt1)/EFI/qubes/grub
  • (hd1,gpt1)/EFI/qubes/grub
  • (hd2,gpt1)/EFI/qubes/grub

you should look for (depending on the number of drives in your machine) …

If it works, you can follow the steps from @apparatus to either add it with efibootmgr or create the fallback path.


1 Like

I got the EFI partition mounted using the rescue shell now… however the instructions say to rename xen.cfg to BOOTX64.cfg after copying the contents of /EFI/qubes to /EFI/BOOT in the troubleshooting section.

My folder does not contain xen.cfg, the only cfg file is grub.cfg in the qubes directory. here are the files:
fonts grub.cfg grub.cfg.rpmsave grubx64.efi xen-4.17.2.efi

so now that I have the EFI partition mounted, I am not sure what to move or rename to the BOOT folder. I also tried running the efibootmgr command but it still did not show up as a bootable device. Any idea why the troubleshooting says to rename files that aren’t present or am I mounting the wrong partition?

Thanks again so much for the help.

I think the xen.cfg reference is from Qubes OS 4.0 (IIRC) - with Qubes OS 4.2, you should look for [something like]

cp -r qubes/* BOOT
mv grubx64.efi bootx64.efi
mv grub.cfg bootx64.cfg


1 Like

Thank you so much! I will bookmark this page so I can get qubes to boot next time I need to update it! I got it booted now, thanks again!

Since the GRUB config has been copied to BOOT, you’ll probably have to copy it again, when Qubes OS updates the kernel/GRUB config …

Edit: Strike that! – I keep forgetting, that Qubes OS 4.2 introduced the unified GRUB config … so you should be fine with the copy (with Qubes OS 4.2, the updates always goes to /boot/grub2/grub.cfg)