Black screen on qubes installation

1 Like

maybe try this latest kernel

I assume that’s post-install troubleshooting but I can’t even install qubes

All your assumptions seems wrong to me.

Maybe. I am not really understand where should I find “failsafe” boot menu? On load I see non gui boot menu with four options:

  • Install Qubes OS R4.1.0
  • Test media and install Qubes OS R4.1.0
  • Troubleshooting - verbose boot and install Qubes OS R4.1.0
  • Rescue Qubes OS system

All 4 lead to black screen except 3rd one. It shows bunch of strings before it.
I also can open grub cli and edit commands of options above.
Ctrl-Alt-F2 makes no difference

Same result

You should have a look at the HCL and find similar hardware there. The workarounds mentioned there might help you.

For example, you GPU is menitoned here and here – both have links for more info.

1 Like

When the boot sequence begins, the GRUB main menu is displayed. Use the arrow keys to select the boot entry to edit (the first one is good choice mainly), then type e to access the GRUB edit menu. Add boot arguments to the line, as suggested on different links posted here (just look for the one most similar to your issue) until you find the working one.

This is where I was able to get to with a GTX980 and get to a terminal.

Does Qubes output to serial port during install? Might be a good option if it’s available.

Dear all,
I am new to the qubes community.
I have just received my Framework Laptop DIY with all the recommended (HCL) hardware. I installed Qubes 4.1.0 from USB. All went fine (got into BIOS, disabled secure boot, enabled restore to factory setting, no messages about hardware problem) until final reboot. Everything hang up. Only non-blinking cursor in left upper corner. And whatever key combination I try, I cannot shut down or reboot.
can anybody help me?
Thank you so much!

Can you describe your actions in more details step by step?
You can check these notes about installation of Qubes on Framework laptop:

I followed the help of Qubes OS on the Laptop - #9 by Mdaly001 - Framework Laptop - Framework Community (I hadn’t see the one you suggest):
“I shut down the framework laptop.
Tap F2 repeatedly to enter BIOS.
Then I disabled secure boot and enabled restoring secure boot to factory settings.
Then I shutdown and booted while tapping F12.
Then I was able to select my boot device loaded with QubesOS iso.”
The Installation screen opened and I followed the official Qubes insatallation guide step by step (as by the website) (even though I now remember, that in the iso there was no choice other then XCFE (no whonix or debian). Last sentence " When the installation is complete, press Reboot . Don’t forget to remove the installation medium, or else you may end up seeing the installer boot screen again." I removed the USB and pressed Reboot, and that was the end of my adventure.
I cannot try anything else since the computer is stuck and cannot get it to do anything.

Now when you boot after installation do get into GRUB menu or you just see black screen on power on?
Do you see Qubes instance in BIOS → Boot > EFI Boot Order?

That’s exactly the point, the computer has frozen. I cannot get it to do anything. It never went into GRUB. Black screen and cursor not blinking. Reacting to nothing, doing nothing. How can I unfreeze it?

Can you enter BIOS or it’s not working as well?

First: Thank you so much for your time!
Whatever I tried, (crtl+alt+F2, crtl+alt+del, esc, power button, …) nothing moving. So not even BIOS reachable.Power button light is on, but nothing happens.

So your problem is you can’t power down or reboot your laptop?
Just hold power button pressed for a few seconds for it to power down.

that’s the problem, but whatever i try, it does not power down or reboot. It’s stuck. So do you any trick to force power down?
If I could power down I could try to boot into BIOS like I did before. But at the moment this is not possible.

Press and hold the power button for a few seconds (3-5+ seconds) for it to forcefully shutdown.

1 Like

Oh thank you so much!
When I first tried this, I didn’t hold down long enough. Now I timed it. Now I will try to boot into BIOS.