Black Screen after GRUB | Installation Issues

Hello Qubes community!

I have scoured (almost) the entire internet for a solution to my problem. However, I found answers either too old for old versions of Qubes (2016-2019), or relatively new (2020-2021), but none of them helped me. Therefore, I decided to open a new topic and ask for help on this forum.

  • Problem: After booting from a flash drive and selecting any item in the GRUB bootloader, I see a black screen and nothing happens, the installer GUI does not appear. I cannot start the installation.

  • What I already tried:
    • UEFI troubleshooting > Installation from USB stick hangs on black screen
    Installation media black screen · Issue #5165 · QubesOS/qubes-issues · GitHub
    • nomodeset=0 in GRUB’s linuz line

  • Hardware:
    • Lenovo Legion 5 15ACH6H Laptop
    • CPU: AMD Ryzen 5 5600H with Radeon Graphics (supports AMD-V and AMD-Vi)
    • GPU: Nvidia GeForce RTX 3060 (Laptop)
    • MB: UEFI-Only (no Legacy Boot available)

• Qubes ISO on USB: 8GB, MBR, BIOS or UEFI, FAT32, DD-style formatted and burned.

Version I try to install: Qubes release 4.1.2

Hi @grefendos, welcome to the Community!

Your hardware is quite new (2021), whereas dom0 in Qubes 4.1 is based on Fedora 32 from 2020. It might be the case that a new kernel would help you. Did you try testing Qubes release 4.2?

1 Like

No, I haven’t tried Qubes release 4.2.0-rc1 yet. Since I want to install Qubes as the main OS, I chose the stable release. But ok, I’ll try 4.2 and let you know!

Yes, it helped! You are the best, thanks!

1 Like