BIOS reflashed on Qubes laptop - need to restore network connectivity

So, I have this laptop with a fully functional Qubes install. However, I reflashed BIOS and now sys-net won’t start, complaining about a missing PCI device (error msg is quite specific, with device number etc.). Network icon doesn’t show. Can’t use either wifi card of Ethernet socket.

The new BIOS is fully functional, incl. network connectivity - tested with a live Linux distro.

Question: is there a way to tell sys-net what PCI devices (wifi & Ethernet) to use, or I have to reinstall Qubes from scratch?


UPD. I can’t even see the settings for sys-net beyond the first tab - all I see when clicking on other tabs is some error message in red for a split second, and then I’m back to 1st tab.

The name in the device list should tell you which device is the network interface.

When you flashed the firmware the device id probably changed, just remove the devices from the device list in sys-net and add them again with the new id.

Thank you. How do I remove/add devices in the terminal, please? I tried to use GUI, but as I said above, can only access the first tab. Clicking on any other ones only gives me a split second glimpse of those with an error message in red.

You can try and add qubes.skip_autostart to the kernel parameters when you boot, if the qubes are offline you should be able to edit the settings.

1 Like

Worked like a charm. Editing one GRUB entry vs reinstalling OS. Much appreciated !

1 Like