Best way to progress as a beginner?

Shalom everyone

I have been using Qubes for the past 48 hours and unsurprisingly it is one mindfuck of an OS. I’ve read through some of the Qubes documentation, messed around with the manager and spinning up disposable whonix tor browsers but other than setting up wireguard to mask clearnet ip thats all I’ve succeeded with. I am very much outside of my element and am thinking about removing qubes all together in favour of standard linux mint, purely for the purpose of gaining some basic linux understanding.

I tried setting up linux mint in a standalone vm with hvm. Everytime I hit ‘boot from cd-rom’ and point at corresponding linux iso in separate qube, the linux mint qube just restarts and does not boot the iso. Naturally I need to look more into this, just seems very overwhelming currently. i2p is my next concern, I’ve read some of the posts here so will go from there.

Any reason why I keep having to hitting the disposable whonix tor browser downloader icon to update the tor browser? I update it through that and then the version downgrades itself.

Other than going through all qubes documentation and spinning up different linux distros, what else can I do to get my head round qubes as a whole other than just plain and simple trial n error?

i did not walk over the sea of galilee to give up so easily.

Merry Christmas and Happy New Year and welcome to the community.

My best advice would be - leave any extra setup for later. Just use default setup until you are used to use it. Do not try even Windows HVM qube, nor any other standalone.
Just test the concept of dom0, templates, app qubes and disposable templates based on them, and sys-xxx and disposables based on the latter.
If you’re ex Windows user and used Virtualbox or VMWare, use Qube Manager - it’ll look familiar.

Just don’t try to set anything extra until you’re more than familiar with default setup.

You’ll anyway reinstall it at some point, for one reason or another: either when you realize your compartmentalization concept, or when you brick yourself experimenting/trying to set advanced setup at the very beginning.

When latter, you’ll quit Qubes most probably.

1 Like

Changes made to disposable vms do not persist. You have to update tor browser from the template. Since running the browser in the template is not allowed for security reasons, you have to use the following command from the root terminal in the whonix-ws-16 template:


You can also add the --onion flag after the command to use the hidden servers, but it’s more likely to time out. If it does timeout, then just repeat this command adding the --resume flag.

To run the root terminal from dom0 enter the following:

qvm-run -u root whonix-ws-16 xterm

By definition, a Disposable is reset every reboot. Try Tor Browser Downloader in the template.

In the worst case, you can use it in the same way as in a normal Linux distribution. You won’t benefit from the compartmentalization, but it’s a good start. It’s definitely not worse.

I’ve tried the tor browser downloader several times now. One of 2 things happen.

1.) it fails to update the tor browser and displays error message, I’ll try and get error message to paste here

2.) it updates the browser successfully but then I end up opening tor later on and it’s somehow been knocked down a few versions.

Yes I did consider regular linux distribution for i2p, that’s actually the main route I’m considering currently. I have setup a standalone vm template with hvm virtual mode and pointed the ‘boot qube from cd-rom’ thing at mint.iso located in the vault but it just won’t boot when I start the standalone vm template.

In which VM did you run it? You should start it in the template, i.e., Menu -> Template: Whonix-ws-16 -> Tor Browser Donwloader

I’ve used that ‘tor browser downloader’ and ‘update-torbrowser’ command within the whonix16 vm. They either fail to update or succeed but then when I re-boot tor browser has been downgraded again.

You should be more precise if you want us to help you. Which errors are shown?

Just checked, and I have Tor Browser Downloader in two different VMs: whonix-ws-16-dvm and whonix-ws-16. After using the former, the Tor Browser is reset to the old version, but after using the latter it stays new as expected. Are you sure you are running the correct one?

Asking here and searching this forum for answers. For example, this question

was discussed here: Template build from a iso.

This is not what I meant. You can install i2p on Qubes just like you would do it on a regular Linux distribution, inside a VM (in a template of course). In such case, you would not fully benefit from the Qubes isolation, but it could be a good first step. For the true Qubes way, you can have a look here: Introducing sys-i2pd.

Also, it’s better to create new topics for every issue, otherwise new users will not be able to easily find answers.

All my updates are routed through tor so whenever I try to update through tor browser downloader in whonix-ws-16 it just times out. I’ve been spending the better half of an hour trying to get my screenshots over into whonix from dom0 to upload here, not sure why I’m finding this so baffling.


Can you update whonix-ws-16, or does it also time out?

This should not be very hard:

Times out.

I have the screenshots in my vault, it’s the getting them from there to my disposable whonix firefox vm part that I’m struggling with. When I open up the whonix thunar file manager I’m unable to locate them.

Thanks for the responses brotthaa. Not sure if it’s because I’ve been looking at this shit for too long or I’m naturally stupid but I definitely need to just properly sit down and fuck around with this shit myself.

Likewise son

Noted. Fundamentals are vital

1 Like

You should check whether your Tor connection is working correctly. For that, you can right-click Time synchronization Monitor widget and open Tor control panel. It should say “Connected to the Tor network!” You can try to restart Tor from there. Also, you can run System check from sys-whonix VM.

They should be in ~/QubesInconming folder.

Yes they are located there in whonix-ws-16-dvm vault, it’s the getting them from there to the disposable tor browser that I’m struggling with.

Seems ok now, will have to restart to confirm updates remain.

Why wouldn’t you use the right-click menu to send them to the needed VM?

I have. Somehow I can see the screenshots when I hit the upload button here in my disposable whonix tor browser and on other image hosting sites, only I get error messages when trying to upload. Here, it just says processing endlessly and imggbb just says ‘some file could not be added’.

Oh and tor browser successfully updated, just needed some restarts so all good there.

1 Like

This exactly the problem with Qubes and new users. Dm me take my course for free. Keep in mind it’s hacking with qubes os. So we will set up and harden the system from scratch. I do it live no BS. Make history with us and take the first ever hacking with qubes os course!