Bad default boot option after dom0 update

Previously, when I booted qubes, I had two boot options: Qubes with Xen hypervisor and advanced options for Qubes with Xen Hypervisor. It automatically booted Qubes with Xen hypervisor.

This day after doing a dom0 update I now have 4 boot updates, and the default boot option that loads automatically gives me a bad version of qubes, that doesn’t work properly. Now I have:

  • Qubes (default boot)
  • Advanced options for Qubes
  • Qubes with Xen hypervisor
  • Advanced options for Qubes

Obviously I want to change the default boot option to Qubes with Xen hypervisor. The menu says I can press “E” to edit selection, but from there on, I have no idea how to actually edit the selection. Any ideas? :slight_smile:

I met similar things before. I tried to boot into an older kernel and reinstall the newest kernel, whch fixed this for me.