Backup Fails since upgrade to 4.1

I’m backing up to secondary disk attached via qvm-block
I’ve tried doing it in different qubes
Hasn’t got past 8.9GB, but last attempt just hung at initial 30K
No error messages from the Backup tool, I just give up and hit cancel when file stops changing (for hours).

I’m using the same workflow I used in 4.0. This is biggest issue I’ve had with 4.1 so far, but don’t see any mention of this by others in the forum. What else should I try? or check?

Thanks.

Could it be this?

Also, is secondary disk internal, or external (USB, esata…). Did you try to write to it, before backing up?

I can rsync files from the connected qube to the disk.

I’m trying 2 different disks. Both are internal esata connections. (1st and 3rd link seem to be addressing USB) One disk I used regularly to backup before upgrading to 4.1, the other is empty.

I tried unchecking the box for compression, that did not help.

Just to eliminate another variable. I tried doing a small backup directly to my home directory within a qube. Same results, it creates the initial 30K file and then nothing happens until I click cancel. The Backup tool is responsive when I click cancel so it doesn’t seem to be frozen itself.

So this is not related the disk at all. Backup is just failing.

Did you try to backup with the command-line tool?

No, good idea.

https://dev.qubes-os.org/projects/core-admin-client/en/latest/manpages/qvm-backup.html

Got it running. Same result, it creates the initial 30K file, which never changes. I used verbose mode, but didn’t give me much info. Listed all the qubes. Asked “Do you want to proceed?” I said “y”, then I entered password, it gave me this:

 2022-01-012 10:25:46,974 [MainProcess selector_events.__init__:59] asyncio: Using selector: EpollSelector 
 Making a backup ... 0.00%

After a half hour i hit ctl-c and it gave me:

  Backup error: Backup cancelled

Well, at this point I’d try create a backup in vault (and later would copy it anyway from there to the other disk).

Not sure why you think vault would work better than other qubes? Trying it now, but so far same results, just sitting at 30K.

Apologize, forget my previous message. English is not my first language. I guess if you’d wrote “I’ve tried doing it to different qubes (meaning to primary disk as well)”, I’d probably understood properly.

I guess it doesn’t matter if you try to back up some small qube only, like sys-net?

Just to be clear: I meant to create a backup in a vault, not to a secondary disk attached to vault.
Also, did you start the qube you are trying to backup to? Did you try to exclude it from backup?

Yes, I tried to do a backup of just a few small qubes in the home directory of vault. Vault is running. Vault was not included in the backup. Same results.

Coming back to this in hopes of not having to reinstall everything.

A factor that determines when the backup freezes seems to be if any of the qubes I’m backing up are running. When some are running, it creates the initial 30K file and never gets past that point. Is there something in 4.1 that requires qubes to be halted during backup?

When I do shut them all down I can get about 10% into the backup before it freezes (which is 9.5GB for the current test), then the same thing happens, progress ceases.