AX500-DBS WIFI not working under 4.1

Hi, does anyone know how to get a AX500-DBS WIFI adapter running under QubesOS 4.1?
I also tried it with kernel-latest - the system does not seem to recognize the adapter.

Check your grub boot parameters. There is a chance that they may need editing.

Hi alzer89,
could you please elaborate? Because right now your answer to my question ("…does anyone know how to get a AX500-DBS WIFI adapter running…") does not do the trick…

Hi alzer89,
could you please elaborate? Because right now your answer to my question ("…does anyone know how to get a AX500-DBS WIFI adapter running…") does not do the trick…

Yes. It was late at night, and I was tired. My bad… :sweat_smile:

Try this in a dom0 terminal:

qvm-prefs sys-net kernelopts ‚Äėnopat iommu=soft swiotlb=8192 iwlwifi.disable_rxq=1‚Äô

There is a possibility that your kernelopts in sys-net are empty. This will fill them with the required parameters that should allow you to use your killer wifi.

Full credit to:

2 Likes

Thank you, will try to give it a shot. Do you know some documentation about kernelopts and how to use them? I was only playing around with it when I upgraded whonix - according to the documentation…

Depending on how deep you want to go down the rabbithole, I have two.

Option A

Light reading, but you won’t understand how or why it works:
https://docs.fedoraproject.org/en-US/fedora/rawhide/system-administrators-guide/kernel-module-driver-configuration/Working_with_the_GRUB_2_Boot_Loader/

Option B

Full-blown deep dive, and you’ll understand the reasons how and why it works, and maybe even find a better way to do it (and hopefully contribute back):
https://www.gnu.org/software/grub/manual/grub/grub.html

The choice is up to you :slight_smile:

1 Like

Hi, it did not work - I can allocate the wifi-adapter to the net-vm but the net-vm does not privide wifi…my work around for the time being is using a wifi-dongle…

That’s very curious.

Just to check, you’re running the latest version of the kernel in sys-net, right?


Also, these might be helpful (emphasis on might):
https://forums.linuxmint.com/viewtopic.php?t=329585
They’re a bit old, but still relevant…

Yep I do 4.1 kernel-latest, never had an issue with other wifi-adapters…
Template (fedora-34) is updated too…running 5.14…