autoStart failing

On Boot, “sys-usb”, " sys-net", “sys-firewall”, and " sys-whonix". I disaboed autostart on boot and i was able to use my keyboard but then i wasnt able to debug the issue properly

Here are some pictures of it failing

I am still fairly new to qubes and im steadily figuring it out along the wa




Is it a freshly installed Qubes OS and you have this issue right after installing it?
Or did Qubes OS work without this issue before but this issue appeared after something happened? Maybe you’ve changed something in Qubes OS configuration or in BIOS or updated dom0/templates?

When you boot with disabled qubes autostart then are you able to successfully start qubes manually?

It worked for about a week after installing it

And yes, i was able to boot & log in

Do you remember changing anything in Qubes OS configuration since last successful boot?

After you boot with disabled qubes autostart and log in are you able to successfully start the qubes (sys-net, sys-usb etc)?

Not with the system

No, it fails because of the kernal param it seems

What’s the message when qube fails to start?

Btw, is there any info i can provide to make this easier for you?

Try to open terminal in sys-net.
Will it open?
If not then do you see any notification about sys-net failing to start because of some error?

I got this error

Try to start vault qube or some other offline qube with net qube set to none and without PCI devices attached.

What’s your vault qube template?
What other templates do you have in your system?
I think your template filesystem could be corrupted and you may need to fix the filesystem.
Check the file /var/log/xen/console/guest-vault.log in dom0 to see if there are any EXT4-fs errors like this:

Templates


It uses fedora-39-xfce

And i checked the log, i ended up grepping EXT4-fs to make itbeasier

The issue may have been caused by leaving the computer on during a period of unsceuduled rolling blackouts that i’ve been experiencing in my region due to excessive heat
Thats the worst i can think of

Change the template of vault qube to debian-12-xfce and try to start the vault qube.

It worked

Then I guess the issue is only with your fedora-39-xfce template.
Try to start fedora-39-xfce template.
If it fails to start then check the /var/log/xen/console/guest-fedora-39-xfce.log in dom0 to see if there are any failures or errors.
But maybe it’d be faster to just reinstall fedora-39-xfce template after changing your service qubes template to debian-12-xfce if you don’t have anything important in fedora-39-xfce template.

How can i install debian 12 in sys-net
It seems like the qube doesnt allow changing its template
I don’t have anything too important, atleast nothing that i cant just reinstall easily

If your sys-net is disposable qube based on default-dvm disposable template then change the template of default-dvm qube.
If it’s not disposable then what’s the error when you try to change the sys-net template?

Its set to fedora-39-xfce and in the qube mamager program, switching it is greyed out