Audio on Qubes

Hi buddies,

I just wanted to listen some music via youtube, but, guess what, no audio. And yes, i’m newbie
Even if i tried to find a clear and step-by-step guide regarding a ,how-to-setup audio" i didn’t found something relevant.
Long-short question: is able someone to provide this kind of guide? Because, unfortunately, on this forum just a ,mixed-salad" discussion can be found.

Sound works out of box on Qubes OS, at least for vast majority of users. That’s why there is no “guide how to setup audio”, because it just works (I am not talking about bluetooth or sys-audio complications).
So, you should diagnose and fix sounds issues for your case. But you provided no technical details of the problem, so it is hard to give any specific recommendations.

1 Like

Perhaps you can also try to open PulseAudio Volume Control from System Tools in the Menu and check the settings there.

1 Like

If you’re using a minimal template, check the docs and install the required package.

@balko i have added few screenshots, even if looks like everything seems to be ok, still no sound

@fsflover I have added in my VM(see in my screenshots)

@adw i think the problem is on the dom0.

Maybe dom0 lacks related firmware. What’s your soundcard’s spec?

@augsch is on the above screenshots

Do you have /lib/modules/$YOUR-KERNEL-VERSION$/kernel/sound/pci/snd-ens1371.ko?

Is it loaded? You can check by running sudo lsmod | grep 1371.

from the pict you send in some device you just need to click that profile, choose other one, then switch back.

go to input and output, do that above, likely fedora bug.

1 Like


@cayce pavucontrol is already installed

@augsch i have checked already :slight_smile:

1 Like

@51lieal i have tried, same result


@cayce if you don’t have something useful/helpful to say please do not overload the topic.


What profiles do you have in Pulse Audio Configuration tab for your audio device?
Select Analog Stereo Duplex profile if you have one. Or some other profile with Analog Output + Analog Input.