Any Operation Affecting Fedora-32 Fails After Fresh Install

Qubes Version: 4.0.4
Running on Lenovo ThinkPad X1 Carbon 5, i7-7600U

Ran this on my mac
cat Qubes-R4.0.4-x86_64.iso | sha256sum

Ran this to write to usb
sudo dd if=Qubes-R4.0.4-x86_64.iso of=/dev/disk2 bs=1048576 && sync

Verified the USB wrote successfully by
sudo cmp -n stat -f '%z' Qubes-R4.0.4-x86_64.iso Qubes-R4.0.4-x86_64.iso /dev/disk2
Returns nothing and this gives the same hash
sudo head -c stat -f '%z' Qubes-R4.0.4-x86_64.iso /dev/disk2 | sha256sum

Here are the steps I followed to install

  • Enabled Virtualisation in the BIOS
  • Booted from USB
  • Selected English (Ireland)
  • Wiped entire disk
  • Created an admin user (root account locked)
  • Reboot
  • Configured Qubes with default options

Refresh applications doesn’t work

  • Open Qube Manager
  • Edit Qube Settings
  • Applications tab
  • Click refresh applications
  • Error [Dom0] Refresh failed, Command qvm-sync-appmenus fedora-32 returned no zeo exit status 1

Run command from dom0 terminal
qvm-run fedora-32 “echo hi”
BrokenPipeError on line 180 of

Run command from dom0 terminal
qvm-run fedora-32 xterm
fedora-32: command failed with code: 1

Run command from dom0 terminal
qvm-run fedora-32 gnome-terminal
fedora-32: command failed with code: 1

Run command from dom0 terminal
qvm-sync-appmenus fedora-32
qubesadmin.exc.QubesException: Error getting application list on line 161 of qubesappmenus/

All of the above works fine on any vm not based on fedora-32, or any other template.

I’ve also tried:

  • Restarting the machine and rerunning all the commands
  • Reinstalling

I’m getting the same output no matter what I do, do you have any ideas?

Changed the language to UK and it works now.

1 Like

It’s weird that that worked. Two questions:

  • you reinstalled with the UK keyboard or you simply changed it in the settings?
  • What was the thought process that lead you to conclude that it was keyboard-related? (just to it may be easier to diagnose the cause of this issue)

(I’ve adjusted the title for more clarity over the problem. Feel free to tweak it)

edit: Thanks for creating a GitHub issue (just came across it). I guess it makes more sense for the discussion to continue there as it does indeed look like a bug.