After update: Wifi not connecting on X230

Hi all,

Been using Qubes for a few months without major issues now, gradually learning to work its quirks and features.

Did an update yesterday, rebooted, now the wifi won’t connect.

I did a pretty good read through the forums but still can’t identify what’s wrong.


Wired internet works without a hitch.

Wifi card is recognized and network manager sees the wifi network that I want to connect to, I can click on it to connect, the network manager circle turns for about thirty seconds, then just stops with the icon being red and a little x in the bottom right corner of the icon.

No error message. It just doesn’t connect.

Tried deleting the network and re-adding it, no cigar.

Other devices connect to the same wifi network with the same wifi password just fine.

I didn’t change anything except updating Qubes. Worked reliably before the update.

Halp please…


Check the log in your network qube (sys-net?) for errors related to wifi. You can run sudo journalctl in your network qube terminal to see the log.

Thanks - did so, got a ton of output none of which I can interpret due to lack of knowledge.

Can’t see anything that screams wifi at me.

A number of potentially concerning error-ish looking lines.

Anything in particular that I’d be looking for?

You’ll probably ask me to post the output, but I think I don’t currently have a means to get the output text from the Qubes machine to another machine from where I could post it here.

Open sys-net terminal and run this command:
sudo journalctl -f -n0
Try to connect to wifi.
When connection fails press Ctrl+C in terminal to stop logging.
Search in terminal window for text “error” of “fail”.

Thank you!

Some finds:

device (wls7): Deactivation failed: GDBus. Error:fi.w1.wpa_supplicant1.NotConnected: This interfaxe is not connected

device (wls7): state change: failed → disconnected (reason ‘non’, sys-iface-state: ‘managed’)


activation (wifi) association took too long, failing activation

Those caught my eye mainly. Does this help you help me?

Failing association is too general of an issue to make a conclusion based on just this.
It could fail to associate because of hardware problems: low signal strength (too far from access point), high noise (many APs on the same channel nearby with high load), wireless controller overheating, antenna cable connection problem etc.
Or maybe some software problem in firmware.
You can try to use newer firmware. If you’re using debian template then you can try to use fedora template because it use newer packages.
Or maybe there is a more accurate log message as to why it failed to associate before this message:
activation (wifi) association took too long, failing activation

Thank you again!

Distance is 4 metres, hasn’t changed.

Not sure how to check if any random noise has been introduced around here, but it happened immediately after the update, so I think it has something to do with that more likely.

Nothing changed in the hardware, unless something died exactly after I did the OS update. Seems an unlikely coincidence to me.

Firmware hasn’t changed.

The only change that I’m aware of is the OS update. It worked moments before, it didn’t immediately after.

I’ll go and have another read through the log file to see if I can find something more meaningful…

Thank you for your patience!

You can clone your sys-net template and try to rollback the last upgrade to check if the problem is in template updates or in dom0 updates:

Hi Jack
What is the WiFi card?(qvm-pci in dom0 will help.)
What is the template used by sys-net?
What was the “OS update” you ran - dom0? The template used by sys-net?