After update, no network except in sys-net

After running an update on my Qubes 4.1 system today and rebooting, I now have no network access from anything except in sys-net. In sys-firewall I can’t ping anything and of course DNS lookup doesn’t work either. Of course all other VMs because they use sys-firewall for networking don’t work either. sys-net is pointing at nothing for networking, and sys-firewall is pointing at sys-net. There is a yellow exclamation point for some reason. It says sys-firewall is the default networking, but that of course would cause a loop.

I updated both fedora-34 and dom0. The kernel was updated. I tried setting to the previous kernel but that didn’t solve the problem. I used the qvm-prefs command to make sure that sys-firewall was set to use sys-net for networking but that didn’t make a difference.

Again, this is using fedora-34, not debian (I know there was a network issue reported with the debian template at one point).

It is definitely not a problem with by ISP as my phone, running Ubuntu on a live USB (which I am using to write this topic) and sys-net (on Qubes) work.

Thanks for any help you can provide.

Can you check if network works for AppVMs based on debian template?

I would try that, but I don’t have that template installed and I don’t think I can install anything with this issue.

Did you try to create test AppVM with netvm set to sys-net and see if network will work for it?

I tried changing one of the existing VMs from using sys-firewall to sys-net and networking still did not work.

I can only think that some updates failed to install or something similar that lead to some software to not work in template.
You can try to install debian template from Qubes ISO or download it from Qubes repo from another system:
Then copy rpm to dom0 and install it there.
Then check if the AppVMs based on debian template will work or no.
If it won’t work then something broke in dom0.

If I am able to get the debian template onto a USB and access it, how do I install it? It seems like all the samples for installation of a template within dom0 show it coming from a repository via the network. Thanks

sudo dnf install /path/to/template.rpm

So I was unable to copy the rpm over to dom0. It said file not found. I retyped it several times. Anyway, I ended up reinstalling 4.1 from scratch. Fortunately, I had a fairly recent back-up. The upgrade from 4.0 to 4.1 had not gone smoothly a while back, and since then things had been a bit flakey. It is working much better now. Thanks for trying to help

Pretty similar to this bug: DNS resolution failure (/usr/lib/qubes/qubes-setup-dnat-to-ns did not run on sys-net) · Issue #5648 · QubesOS/qubes-issues · GitHub