After power outages I've lost ProtonVPN gui and cannot get it back

After a series of power outages last week, I lost my protonvpn gui access in my Standalone protonvpn-debian11 vm, which is the net-vm for my other vms. I can still use my ProtonVPN after clicking the enable box in the upper tray for the last-used-server after a reboot. The vpn works, but the gui which I like to use to change servers is gone. Renehoj was very helpful last time assisting me in getting everything up and running and I’ve tried re-following those steps, but cannot get the gui back as of yet. Missing something and cannot figure out what. Following the thread posts from last time to get the gui running, I think this is what I did:

Start Terminal in the protonvpn-debian11 standalone vm (which starts automatically on boot.)

sudo apt install protonvpn

(seems to install ok)

sudo apt update

Reboot computer and when Qubes starts, click on the Ethernet Network Connection button in the top tray, then click to enable the last-used-server. ProtonVPN then connects fine.
Open the Terminal again in the protonvpn-debian11 standalone vm.


Error code appears, “Unable to locate package protonvpn”

Seems like the package isn’t persistent. But if I try to install protonvpn again with

sudo apt install protonvpn

, I get:

protonvpn is already the newest version (1.1.0-1).

Try remove and then install the package again:

sudo apt purge protonvpn
sudo apt install protonvpn

Proton launched the new VPN app last week, that could be given you some trouble.

I would pruge protonvpn and install protonvpn-gui and protonvpn-cli, then you have the old tools again.

Thanks apparatus, Looked like a good suggestion, but unfortunately I still cannot gain access to the gui.
And thanks renehoj, maybe the new launch just happened to coincide with my power outages here. I’ll purge protonvpn and reinstall both of those progs from the ProtonVPN site.
Will report back, cheers

I’ve been trying to get my Proton vpn set up again from scratch in a new Standalone vm, set up in Qube Settings to be identical to the old one and starting automatically on boot. But I’m stymied at the configure vpn in the network manager tray icon. I was hoping not to need to mess with the original Protonvpn vm until, I had the new one working. In the new vm I finally have both the cli and gui programs installed, but cannot access the gui, until the vm has started (from the tray icon). I downloaded the .ovpn zipped configuration file and unzipped it, to have all available servers. My Proton account is of the Unlimited type, so there isn’t any restriction on available servers there.
On the old Protonvpn vm I had a .pem CA certificate a username and password, etc but I don’t know how to recreate that for the new Protonvpn vm. Not seeing any reference to certificates, etc on the Proton site.
Can I safely purge the old vm’s cli and gui programs and reinstall without losing the vpn configuration from the tray icon? I feel like a bit of a dummy, since I’d successfully fumbled through this before.

You can just clone your VM using Qube Settings and test your changes in cloned VM before you make them to your main VM.

Thanks apparatus. Sounds good. I’ll do that and report on the results.

No joy yet. I cloned the protonvpn standalone vm that did successfully connect before (albeit with no useable gui any longer) and made the clone the only protonvpn vm that starts on boot. I changed one of my day to day vms over to use the new clone for its Net Qube, then rebooted. Worked fine except no gui access as expected by entering protonvpn in Terminal. In terminal I ran

sudo apt purge protonvpn

Copied the v3 protonvpn-cli repo deb file to the Protonvpn Service vm. Also copied in their VPN app for the gui, in case I needed that.
In Terminal of the Protonvpn Service vm I ran the following commands after cd’ing into the download folder:

sudo apt purge protonvpn

sudo dpkg -i protonvpn-stable-release_1.0.3_all.deb

sudo apt update

sudo apt install protonvpn-cli

sudo apt install proton-vpn-gnome-desktop

There was one message about a python3 file not being the same on the system as in the package. But everything seemed to install fine otherwise.
Rebooted, in the vpn applet in the top desktop tray I connected the vpn by clicking in the Vpn Connections box, which started the vpn with the server previously used. Protonvpn up and running. However in the protonvpn Service vm’s Terminal I have no access to either the cli or the gui programs. Any entry for either yields the error message,

bash: protonvpn: command not found

I cannot manually change servers with for example,

protonvpn-cli c --cc CA

This wouldn’t be a permissions problem, might it? I’ve also entered

sudo apt update && sudo apt upgrade

at one point, which I think solved the python3 problem, but not sure on that. And a couple of reboots, in case that might make something “catch” and get enabled. Stabbing in the dark at present, I’m afraid. Looks to me like the vpn is there, but won’t give me access.

Don’t you have to use protonvpn-app instead of just protonvpn? I’ve just tried to install proton-vpn-gnome-desktop in appvm based on debian-12 template and I can run protonvpn-app there after installation.

I’m relatively new to Qubes, so forgive me, not hijacking the thread but for ease of use, for me at least, was to purchase Invizbox 2 I simply boot and click my Proton VPN 5G.
So much easier than trying to set up networking!! :grinning:

Mixed results. Thanks apparatus. protonvpn-app did work in place of just protonvpn, which my old protonvpn installation was using. I still don’t have access to the protonvpn-cli method though. And each time I boot up, I now need to start Terminal in the protonvpn vm, to connect the vpn, which is different than what I was used to. But it’s great to have a vpn again, in which I have the ability to change servers. Thanks.

1 Like

How to install the v3 Linux CLI
Debian-based distros

If you have the official (v4) Linux app installed on your system, you must first uninstall it. To do this, open a terminal and run the following:

sudo apt autoremove “protonvpn*” proton-vpn-gnome-desktop

You should have the “Proton VPN” application available in Qube Settings → Applications after installing proton-vpn-gnome-desktop in template.