4k loading screen before login

Hello, I have a 4k display 15.6’’ laptop. I have adjusted the DPI value, so the font in Qubes itself look good. But the loading screen before the disk encryption font still thinks I have a 4k display. In the BIOS, there are no settings to adjust the screen resolution. Does anyone know how to fix the small font of the booting screen?

Update: I have tried to update the (dom0) /etc/vconsole.conf with the following settings.


The booting (dm-crypt?) font remains the same (small).


Hi @user2,

I think that the loading screen before the disk encryption is managed by Plymouth. Can someone, here, confirm this?

So I suggest to search on this way, with the help of the Archlinux’s Plymouth wiki page (Hidpi section).


Thank you for your answer.

According to the PlymouthHidpi manual, after changing plymouthd.conf, the initrd needs to be rebuild. Is it applicable for qubesos? If yes, how to do it?

Initrd is a dangerous process if not well done. You could get an unbootable Qubes OS.

I know how to generate a initrd file with basic Linux distributions (for example with ArchLinux, Grub menu available on boot, and secured with multiple entries in Grub menu), but not for Qubes OS. So you need the help from a skiller user.

You can also wait the next kernel update, in general (also for Qubes OS?) the initrd file is re-generated on kernel update (so with your new HiDpi option).



The Dracut Fedora tool generates the initramfs, it’s also documented in the Qubes OS installing-kernel-in-fedora-vm process.

See also the icequbes1’s post about the boot process :

and the mgflax’s question about dracut:

But I repeat, do it only if you understand the commands and the risks (:boom:)…