4.1rc1 fail to install with blank screen

So I just got my new ASUS Prime Z590-P with i7-10700K and tried to install 4.0.4 where I got to the first text-based screen but after that I get a blank screen and the monitor goes into sleep-mode. So read some more and figured it has something to do with the onboard intel graphics [UHD630] so I tried 4.1rc1 which ended in the exact same result.
Tried to install Ubuntu18.04 - same result.
Tried Mint 20 with “safe graphics” option and it went well for the duration of the installation but not past the next reboot.
Reading some more I understand that it has something to do with i915 (not exactly sure what it is)
Only OS I managed to fully install so far is Fedora34, and even there the display is “stuck” on 1024x768 which (obviously) isn’t by monitor resolution (because we’re not in the 90’s any more).
When installing 4.1rc1, the last line I got before the screen went blank is:
(XEN)Xen is relinquishing VGA console.
but I have no idea what it means.

I’m using 4.0.4 for almost two years now and can’t imagine using anything else as my daily driver, but my current rig is 8 years old and I’d really like to be able to use the new one instead of letting it “mature” in the closet, so… help?? :innocent:

1 Like

have you try adding i915.force_probe=* after .......plymouth.ignore-serial-consoles quiet so the line look like this ...... quiet i915.force_probe=* in kernel option ?

I believe I did but wasn’t sure, so I just did what you suggested - exact same blank screen result. I wonder if it has something to do with kernel version of the installation for 4.1rc1 being too low/old while more recent kernels have a solution.

my laptop has i7-10750h which use intel uhd630, well if i try boot with uefi it shown glitch and blank, if i use discrete (gtx 1660 ti) it will works.

have you try boot with bios ? with no need to change / add anything into kernel / media installer.

Apparently, intel decided that when using the integrated graphics card we shouldn’t use CSM so this option is disabled. (Why can’t I enable CSM on my new motherboard? | Scottie's Tech.Info)
Best I could do is delete the secure boot keys but I’m not sure if it’s the same as going Legacy-BIOS.
If the only option is to have a discrete graphics card then I’ll probably have to get one (even though it feels like through money down the drain) :angry:

This thread (4.0.3 Qubes installation failure with Asus B460M-A motherboard - #5 by Jansen227) caught my eye with the line:
“UEFI boot gave me a blank screen after “Xen is relinquishing VGA console”, but when I tried legacy boot the installer showed up and Qubes installed without any problems.”
because it looks exactly like what I’m getting, except I can’t go Legacy-BIOS.

So I’m not sure if it’s a kernel thing and I should wait some more for 4.1rc2 to come out with a newer kernel that will solve my problem, OR purchase a graphics card and hope I’m not getting myself into more trouble with its’ drivers as well.
Not sure what to do… :fearful:

In my case, it’s only in the install section you got black screen (uefi + intel udh 630), after install there’s only a glitch in plymouth, and it happen since 4.0 to 4.1, Dummy gpu like quadro 290 nvs is enough, around $10 at ebay.

(System requirements | Qubes OS) says:

  • Intel integrated graphics processor (IGP) strongly recommended
  • Nvidia GPUs may require significant troubleshooting

So you suggest that I install a GPU just for the duration of the installation and remove it afterwards?

From my perspective IGP is really recommended because it works out of the box for BIOS, In my laptop Intel UHD+BIOS will work but not with UEFi, I dont like bios so i use UEFI. that way in installer i use discrete only (gtx 1660 ti) to install then change to hybrid mode after install and using i3 would glitch in some window if use intel uhd, using 1660ti everything is works without install anything (no glitch) but since using that gpu require more power i dont use it after install.

I have this exact same issue. I have all the “Recommended” hardware but I cant get past the (XEN)Xen is relinquishing VGA console.

Last night I managed to install 4.1rc1 with GT730 graphics card.
I didn’t try to take it out and see if the OS is coming up ok after I finished the install.
I understand that it is recommended to prefer the IGP over an external graphics card so tonight I will try to install 4.0.4 (stable) with the GT730 and if it goes well then I will try to remove the GT730 after install and see if everything is coming up ok.

I’m sure that it will okay, but lets try and let others know.

Update: Installing 4.0.4 with the GT730 inside went ok, only to find out that the 4.0.4 kernel doesn’t recognize the onboard RTL 2.5GB ethernet card.
So I installed the 4.1rc1 again, made all possible (stable) updates and tried to start the machine with the onboard intel_UHD630 (leaving out the GT730). After the initial text screen I got a blank screen again.
So I reinstalled the GT730, and quickly realized my mistake since the kernel of dom0 is 5.10.71-1, which is apparently too old to recognize the intel630.
I tried looking for a newer one with:
sudo qubes-dom0-update --enablerepo=qubes-dom0-unstable --action =list kernel-qubes-vm
but all I got is the 5.10.71-1 I already have.
I found mention of the 5.14.10 kernel in here: GitHub - QubesOS/qubes-linux-kernel: Qubes component: linux-kernel but I’m not versed enough in dev/github to even understand what this mention mean and whether the 5.14 release is around the corner or better not to hold my breath.

ps. I really hope to find an easy way to export/import my interface/desktop environment settings from 4.0.4 to 4.1 or I will be forced to spend allot of time manually configuring whisker and the other settings.