4.1 not enough space to install Solved!

Ok, so now trying to install my templates in 4.1. Moved what I wanted to dom0 doing my installs and in terminal it is stating not enough space template needs 60mb more. Why?
Qubes 4.1 is installed on 1.5tb and only have used 7 percent

Here is the thing for that problem. If you wanted to install the template, just in put this command in DOM0:

sudo rpm install Your_Installation_Package

Otherwise use the following in DOM0:

sudo qubes-dom0-update qubes-template-Package_Name-Package_Version

or

sudo qubes-dom0-update --enablerepo=qubes-template-community-testing qubes-template-Package_Name-Package_Version

Thank you but I believe my problem is this…

So in dom0 where are “user” is setup. Where the folders of our user are
( documents,downloads,pictures).
You know /home/user/

Well my user only has 14.2gb of free space and I need more. So I can copy over my templates from my external SSD to dom0 so I can install them?

So how do I increase the free space from 14.2gb to much more for my user in dom0?

Install partitionmanager and resize. Also, in unman’s notes on Github you can find how to resize it in terminal.
qubes-dom0-update kde-partitionmanager

@enmus, REALLY! That’s awesome I thought I was stuck at this size of only 14.2gb for my user.

Anyway I am using xfce in qubes,why would I install…kde-partitionmanager?

In XFCE, you could probably use gparted instead.

I haven’t had luck with gparted because I didn’t see anything, and found partitionmanager way much more intuitive.
Try both and you’ll know what I’m talking about, then uninstall the one you don’t like.

@enmus yes I have used “gparted” and it does take some getting use to. I will give this kde-partitionmanager a try so I can increase my user space cause 14.2gb is way too small for free space. I need more to move over my image files and hvm’s so I can install them.

1 Like

In 4.1, dom0 is pegged at 20G by default.
This means that you will not be able to install the larger templates, like parrot, without taking some action.
The easiest thing to do is to increase the size of dom0. On a default install you can do this simply enough by:

sudo lvresize --size 40G /dev/qubes_dom0/root

sudo resize2fs /dev/mapper/qubes_dom0-root

https://qubes.3isec.org/Templates_4.1/

Installed kde-partitionmanager and looks way better then gpatted. But I can’t seam to figure out which one I need to increasefor dom0 /home/user.

But you thank you for these cmds…

sudo lvresize --size 90G /dev/qubes_dom0/root

sudo resize2fs /dev/mapper/qubes_dom0-root

I have qubes installed on 1.5tb so size doesn’t matter for me what I increase ( dom0 home/user) too.

Can you or is there a “screen recorder” available too install in dom0 like OBS studio? I see screen shot and use it but would like to also record videos. The problem is IF you have a screen recorder installed in a template and try to use it, within the template, well it doesn’t work right, believe me I have tried.

If some of the posts helped you, please flag it as solution, so other users could benefit from it, too.

best regards,

P.S. Regarding screen recorder, my strong suggestion is to open separate topic. It’ll get better visibility and attract users to a specific question, since probably no one would expect to find out about screen recorder in a topic with current subject.

You choose qubes_dom0 in the upper left, “&Devices” window, then select /dev/qubes_dom0/root in the right, “Partition” window

@enmus
Yes I did, if I did it right?

I will start “new topic” for dom0 screen recorder, thank you

1 Like