4.1 Installation Fails on iMac (mid 2011)

Error message: Warning: Could not query variable store: 0x8000000000000019

Trying to boot 4.1 from USB flash drive onto iMac 12,1 (Mid 2011)
2.7 GHZ Intel I5
16GB 1067 MHz DDR3
AMD Radeon HD 6770M 512MB
Boot ROM Version:
SMC Version (system): 1.71f22
USB EFI Flash Drive Location ID: 0xfa130000 / 4

I barely know how to use Mac Terminal, totally new to Linux.

I have downloaded Qubes OS 4.1 from Qubes-Os.org directly, also from 3 different mirrors found on Qubes-os.org website.

After downloading Qubes, I use BalenaEtcher app to burn .iso to USB flash drive. This process seems to be successful. BalenaEtcher has been successful for flashing the other OS’s I listed below. I have successfully burned 4 different Qubes 4.1 .iso’s onto each of 4 flash drives I have (total of 16 attempts to boot Qubes 4.1).

I’m using 4 different generic 64GB USB 2.0/3.0 flash drives. I have used each of these drives to successfully boot TAILS OS, Solus Budgie, EasyOS. Qubes OS 4.1 is the only one giving problems. So I believe the USB drives are good.

Process for Verifying Qubes OS shown on Installation pages is *way over my head, so many steps in Terminal.

Any suggestions will be greatly appreciated.

Hi @jw7 and welcome to the Qubes OS community. Installing Qubes OS in itself can be tricky and will only work on certain hardware. Apple hardware too. The only successful iMac install reported by @alzer89 was for an iMac (15,1) discussed in this thread.

You might be better off picking a computer from the community-recommended list.

Thanks, Sven.

Yes, I had read that thread, no joy.

Sigh, I can’t afford another computer, guess I’ll try EasyOS.

I appreciate your reply very much!!

@jw7, have you tried Qubes OS 4.0.4? That will probably work.

Try to install one of these:

If 4.0.4 can’t query the variable store, then try 4.0.3. That will definitely boot.


You won’t get some of the hardware virtualisation features, but you’ll more or less get the majority of the Qubes OS experience.

The problem is that Qubes 4.1 needs some CPU functions that the custom-designed CPUs put in Apple hardware simply don’t have. That’s partly why it could not query the variable store at boot, because it simply isn’t there inside the CPU…

Well, it’s never too late to start, and once you get comfortable, you’ll wonder how you ever did without it :slight_smile:

1 Like

Thank you, alzer89! I am downloading 4.0.4, will try booting tomorrow, busy day today.

This is your Mac, right?

There will be a few things you’ll need to be aware of:

Xen - The hypervisor that Qubes OS uses to allow it to run virtual machines
Broadcom - A company that makes hardware and notoriously HATES open source (basically nVIDIA, but for networking hardware)

Broadcom wifi cards in Apple hardware will likely not play nice with Xen

The Apple EFI Boot ROM (BIOS) likes to initialise EVERY component in your machine, including the wifi card (this is how Apple’s remote recovery can work). The EFI doesn’t seem to like to relinquish control over the Wifi card to anything other than MacOS (still haven’t figured out why….).

Linux boots on most Apple hardware by loading a barebones version of the mach_kernel that tells the EFI that it’s MacOS, and then it hands complete control over to the Linux kernel to complete the boot.

The problem with this is that the EFI might still hang onto the Wifi card.

Because of this, if you pass it through to sys-net, it will cause your entire machine to freeze.

Here is the workaround:

Your GPU is a Radeon, so resuming from sleep might not work properly

It’s a desktop, so this isn’t really as a much of a deal-breaker as it is if your machine was a laptop.

AMD have made a lot of progress fixing their drivers in the Linux kernel, but they still do some weird things when running through Xen, like locking up and causing your display server to crash, and you’ll basically have to hold the power button down and hard reboot.

The Initial Setup Wizard that runs on first boot after installing Qubes OS will likely freeze when “Setting Up Networking”

This is because of the Broadcom Wifi card. Explained in the first point.

Have a non-Apple USB keyboard handy. You’ll need it

Qubes OS 4.0.3 comes with kernel 4.19, which might be missing a lot of drivers and firmware for Apple hardware.

Have a USB keyboard handy

You’ll have to install the latest kernel by doing this:

Qubes Menu → Terminal Emulator (the second from the top)

Type in:

sudo qubes-dom0-update —enablerepo=qubes-dom0-current-testing kernel-latest kernel-latest-qubes-vm

After you reboot, you should be able to use all the hardware inside your machine properly.

Have your Qubes OS Install USB handy

You’ll probably need to boot from it several times to “rescue” your install if it freezes.


If you run into any troubles, we’d be happy to help. Post them here and we will do our best to get Qubes OS up and running for you :grinning:

1 Like

Thank you again, Alzer89. I very, very much appreciate the time and thought you put into helping me. Basically, that is my iMac. I bought it refurbished, and don’t have a list of the different hardware used (it’s somewhat upgraded from original). I know I can type the hardware info from the System Info window (no copy/paste available), but bottom line seems to be that I want to boot Qubes from a USB flash drive, and while 4.0.3 and 4.0.4 both at least start from the flash drive (unlike 4.1), both versions want to install to my hard drive by overwriting it in order to boot to full operation. I don’t want to repartition my hard drive, I have had problems in the past, “un-partitioning.” So, I will wait to use Qubes until I can afford to buy another computer. Meanwhile, I will use ProtonVPB and Tor browser for browsing, and Status or Sessions for messaging.
Thank you again for your generous and exceptional help!!!

DISCLAIMER: Forgive me, when I don’t exactly know how tech-savvy someone is, I explain EVERYTHING, just in case. I apologise if it comes across as patronising or belittling. That is not my intention. You might know your way around a computer very well (and you probably do), but I’ll still explain everything just in case someone else stumbles upon this thread, and I want to make sure it can help them too. :slight_smile:


Apple hardware (at least, anything after 2014) is notoriously uncustomisable. They do this deliberately so that their software just “works”, and don’t have to write drivers for a million different internal types of hardware. Good for their business model and third-party developers of MacOS software, but terrible for anyone who

Secondly, a lot of their internal hardware are usually custom made for Apple. Even though Apple might say in their tech specs that the iMac has a Radeon GPU, or an Intel i5, they’re NOT the same components/designs that are in the retail versions of those components.

You’ll notice that your CPU has some weird model number (probably ending with an “S”) that you can’t find much info on. That’s because they’re often components that have been custom-made to go into that specific model of Apple hardware. If Apple didn’t want to write software for a certain function/capability of a chip, it would be completely removed from the hardware design. It made production cheaper, but reduced their functionality, so it was kind of a double-edged sword….

It’s a little off-topic, but anyone in the Hackintosh community will tell you that getting MacOS to run on non-Apple hardware is “finicky” at best. Sometimes you’ll even see them actually recommend swapping out your internal hardware to something that actually came inside of a Mac!

It’s highly likely that that’s your Mac. I hope you put 32GB of RAM into it :stuck_out_tongue_winking_eye:

A bit tongue-in-cheek, but Apple has always been a late adopter of cut copy and paste :face_with_hand_over_mouth:

It’s probably because that was the only other drive that the installer could find in the machine.

If you have formatted your drive with APFS, resizing that is a bit of a pain. If you’ve used HFS or HFS+, you should be able to shrink that partition with diskutil (or “Disk Utility”, if you prefer the GUI).

If you still don’t want to play with your internal drive (which I completely respect), have you thought about installing it to an external USB drive?

You can do this. Just for the sake of completeness, you can install Qubes OS onto anything you can store files on. So an SD card, external hard disk, etc. will all be fine. Even a USB flash drive is fine for you to at least “try” it out.

Ideally you want 64GB, but you might be able to get away with 32GB (if anyone wants to correct me on this, please feel free to).

The only thing is, do NOT create a USB qube. Your machine will pass through the USB controller containing the OS, and Qubes OS will implode.

You’re more than welcome to try it if you’re curious, but just be ready to hold the power button down and hard reset it :stuck_out_tongue_winking_eye:).


That would allow you to at least give it a go.

You just have to hold the option key down at boot and select “Qubes OS”. The devs actually made a pretty nice icon for that menu, too.


I was NOT offended at all, I very much appreciate the detail!! When I’m trying to help others, I try to go step-by-step through whatever the subject/process. Back in the day I knew a little about hardware and software, now not so much, and I don’t want to become an expert again, lol. So your advice has been VERY helpful.

I have tried loading Qubes onto several USB sticks, it boots into Qubes but QubesOS never fully starts. This is why I’m so frustrated.

I am exploring Kodachi, Tails, and EasyOS, I am able to boot each of these from USB sticks. Maybe future updates of Qubes will work for me, or maybe I can find an affordable laptop to test Qubes.

Thank you again, alzer89, very much!!


None of these use Xen or use much virtualisation. That’s why they boot fine on older hardware, before virtualisation was the latest fad in CPUs.

What exactly do you mean when you say this?

How far into booting the installer ISO do you get?

What exactly happens? There’ll be a fix/hack/workaround for whatever you’re experiencing.

If you’re booting into Qubes OS 4.0.3 after a fresch install and you’re not getting past the “DUNNNNGGGGG!” and a black screen, you’ll need to add this to your xen.cfg kernel parameters:


Basically, after you finish installing it, and before you reboot, press Alt + Ctrl + F2 to get to a tty.

Your freshly installed mint Qubes OS will be mounted at /mnt/sysimage.

You’ll need to open up the file /mnt/sysimage/boot/efi/EFI/qubes/xen.cfg.

Make it so that your xen.cfg looks something like this:


#Scroll right to see mapbs=1 & noexitboot=1
 [4.4.14-11.pvops.qubes.x86_64] # Or whatever kernel there is
 options=loglvl=all dom0_mem=min:1024M dom0_mem=max:4096M
 kernel=vmlinuz-4.4.14-11.pvops.qubes.x86_64 root=/dev/mapper/qubes_dom0-root rd.lvm.lv=qubes_dom0/root rd.lvm.lv=qubes_dom0/swap i915.preliminary_hw_support=1 rhgb quiet mapbs=1 noexitboot=1

(Maximum respect to the devs for including vim in the installer ISO by default, by the way :sunglasses:)

After that, you can reboot, and that should get it working.


Thanks for following up. I hold down the Alt key, choose the Qubes USB drive “EFI” and then choose the first option that shows. The screen goes black for a few seconds, then this message comes up:
Warning: Could not query variable store: 0x8000000000000019

Nothing happens after that. I have waited as long as 20 minutes, then I must physically power off the iMac. I have tried each boot option Qubes offers, same error message and result each time.

Thanks again!