($100 XMR BOUNTY) No bootable devices found after swapping SSD to new machine

Hi, hoping someone can help me:

I swapped my NVME drive from my old computer to my new computer, it contains an installed version of qubes with all my data. However when I try to boot from the new computer it doesn’t detect it as a bootable device

And yes, in the bios it recognizes the SSD, I’ve tried all other m.2 slots as well to no avail.

Note: if your solution requires booting the install media qubes.iso off a flash drive and any sort of rescue media stuff through that, it won’t work. For some reason my new computer refuses to recognize DD flashed drives as bootable drives, but when I pop it back into my old machine it has no problem booting from it. (Rufus) Also flashing as a regular iso doesn’t work, it boots however I encounter the timeout problem so it seems like DD is required. & no it isn’t the flash drive that is the problem, I’ve used 4 different ones, it’s just machine specific for whatever reason I don’t know why.

If someone can either get my ssd to boot OR get the install media working again so I can just reinstall qubes that would work. Thanks!

Forwarded post #1 does not work as my bios does not support a legacy mode

Forwarded post #2 does not work as I am not able to boot in a rescue disk as I said in my original post

Do you have any other suggestions?

Did you try to disable secure boot?

If disabling secure boot doesn’t result in Qubes becoming a boot option, put the rEFInd Boot Manager on a usb-attached disk and see what refind finds. With exception to coreboot and a small handful of other open source projects around uefi, pretty much all firmware on x86_64 are a total s***show.

if disabling secure boot didn’t work, try this, so UEFI loader has an easier time finding Qubes OS:

  1. stick your Qubes drive back into your old computer and boot
  2. open terminal in dom0 and run:
    sudo cp -r /boot/efi/EFI/qubes /boot/efi/EFI/BOOT
    sudo mv /boot/efi/EFI/BOOT/grubx64.efi /boot/efi/EFI/BOOT/BOOTX64.efi
  3. power off the old computer, stick the drive into the new one and try to boot

adapted from the accepted solution of [MSI PRO H610M-E DDR4] Cannot boot Qubes after a successful installation

I actually cleared & disabled secure boot as soon as I got the system.

If it was a secure boot issue it would display “secure boot violation” instead of “boot device not detected” for reference

1 Like

I wonder if the issue is just a lack of a boot entry on the system. I’ve had a similar issue myself, and I realized that while the boot partition was there on the drive, some devices have you make an actual EFI boot entry in the firmware for it to be recognized as bootable and appear in the boot order list. Typically I do this by just going into an EFI shell.

Refind did find qubes and I was able to boot into it

however it totally broke my qubes installation, many services were not running as it could not find the PCI device or whatever core systems to run qubes were missing and I couldn’t launch any single qube

Then I got the idea of booting into my qubes installation media through refind, but it was also broken, freezing on the setup screen

I appreciate your help though, the hardware I have is very weird

Directory /boot/efi/EFI/BOOT/grubx64.efi not found

I booted into the efi but writing the boot entry

bcfg boot add 001 QubesOS \EFI\qubes\grubx64.efi

However it failed to access the file, thus I was unable to manually create a boot entry, unfortunately.

To everyone here:

I’m pretty much giving up on this. It’s pretty evident that the hardware Im using just hates qubes with a passion.

For reference the system I was using is the
Intel NUC 12 Enthusiast (NUC12SNKi72)

Even when I did manage to get a very broken version of qubes running by jumping through hoops with refind (core system qubes were unable to run),
it absolutely hates the Intel Arc gpu & integrated graphics, very choppy, slow and sluggish and to top it all off you’re zoomed in 200x into the desktop unable to adjust your screen with the display settings in dom0. Avoid this computer. Even using refind to try & boot to the usb install medium breaks it.

TLDR: the solution is to get a different computer

@zero , is a matter of the system (in this case Qubes) to be run anticipating to encounter this chip. Suppose one of these computers were sent to a Qubes dev or an advanced Linux user such as myself we could advise you what time is needed to add what software changes or inform you that (due to what the chip manufacturer has yet released) the thing won’t work yet.

Where we can best help you is by informing you of machines that are known working. Open source projects need your participation. Sharing that you are using that specific NUC and things did not work, does help us, so thank you for sharing this.

1 Like

Similar problem with a Dell Inspiron laptop. Would boot unless it was Tuesday and I forgot to cut the lawn and I need to trim my toenails. Switched to a Legion. Good so far.

It is mentioned in multiple places that the Iris Xe graphics in Intel 12th gen (and later) requires installing the latest kernel for dom0 (sudo qubes-dom0-update kernel-latest) to function properly, e.g. here: https://forum.qubes-os.org/t/framework-laptop-12th-gen-alder-lake/14177 (do a search for intel 12th gen kernel-latest). I think this should allow you to use at least the integrated GPU normally. Did you do this already?
As for the dedicated Intel Arc A770M GPU - maybe you can attempt to pass this device through to a HVM for any accelerated graphics (e.g. games) or higher performance compute needs.


Just tried doing this on both the Nuc 12 Enthusiast & a Nuc 13 Pro I had been testing since I gave up on the 12 and it worked beautifully on both machines with the Xe graphics. This causes me to suspect it’s just a giant issue with fresh hardware and not the Arc GPU.

The graphics weren’t all messed up anymore on either machine and the machines were bearable again.
However, no qubes can start, because

“pci device dom0:59_00.0 does not exist”

Really any VM won’t launch no matter what:
Sys firewall
Sys Whonix
Sys net
Any of the fedora qubes (personal, vault, work, etc.)
My personal windows qubes won’t launch

None of it works, and this is what I meant by “my installation breaking” in previous posts

I’m gonna be honest, I really don’t know what it means, but I’m guessing that it has to do with the fact I installed on a regular machine, and have been transferring around to new hardware which causes it to break. based on what I read and also the fact that I can pop it back into the original machine and have it working just like regular.

I also don’t understand the solution on that linked post, how does one remove the 0003000. Im not that technically inclined. I’m a newbie to qubes.

Any insight is appreciated

Looks like this is one reason why the recommended way to migrate to an entirely different computer is to perform a backup on the old one, install a fresh Qubes OS on the new one and then perform a restore of that backup on the new one, as described here: https://www.qubes-os.org/doc/how-to-back-up-restore-and-migrate/#migrating-between-two-physical-machines. I haven’t done this before, but as far as I understood, these backups don’t cover dom0, which would mean you’d lose any customizations to dom0, such as packages installed to it and the desktop environment settings. So if you are going to do this you may want to think of this or research it, if it matters to you. You’ll want to manually select a kernel-latest option when booting the Qubes OS installer on the new PC, as mentioned here: https://www.qubes-os.org/news/2023/03/15/dasharo-fidelisguard-z690-first-qubes-certified-desktop/#special-note-regarding-the-need-for-kernel-latest.

Alternatively, you may try to manually fix all the issues arising from changing the hardware. The one you’ve just described makes sense to me: “pci device dom0:59_00.0 does not exist” must refer to a network adapter belonging to your old hardware, which cannot be found and passed through to sys-net any time you try to launch it. Likewise, any other VM which needs sys-net tries to launch it and fails. The solution suggested in that topic, in your case would mean:
Open Qube Manager, right click on sys-net, click Settings, click Devices, click << (to remove all the old network adapters, assuming none of them can be found on the new computer) and then look at the list of Available devices on the left and find all the network adapters you’ll want to use (look for something like Intel® Ethernet Connection i225-LM and Intel® Killer™ Wi-Fi 6E AX1690 (i/s)), click each one of them and then click > to add them to the Selected list, and finally OK and try to start it. If you ever get an error message like “unable to reset PCI device” you’ll need to go back to the Devices tab and click Configure strict reset for PCI devices at the bottom and click on the devices which need it (you can check the Documentation page on the website for the articles called “How to use PCI devices” and “PCI troubleshooting”).

Edit: If you have a sys-usb qube you’ll also have to repeat the same steps as above for USB controllers, rather than network adapters. I’m not sure what other issues (if any) may pop up related to the change in hardware.

Note that if you later want to return that same disk to the old computer you’d encounter the same “device does not exist” issue, so if you want to setup a disk for quick migration back and forth between different computers we may have to think of something better (maybe a separate sys-net qube for each computer?).

Honestly, this was always the plan from the beginning. However not everything works out the way I want, or need. In my case both machines refuse to boot off of a DD flashed USB stick, no matter what the drive is. I even tried hopelessly trying to create a boot entry in the uefi shell until I realized the drive wasn’t even being registered because it has to be fat32 or whatever.

That’s why I’ve shifted my focus on trying to get the ssd to work in a new machine rather then making a fresh install, and I’ve actually made progress with it unlike the USB drive fiasco I went through.

Anyways, thank you a lot for the explanation, I’m going to try your fix for the pci adapters as soon as I get the chance, you’ve been incredibly helpful.